why it's not the same scale when imported?

hi everyone,
when i import an image without vectorization in a layer. “fit” enabled : the image is fited with the good resolution in the preview screen.
but when i import an image with a vectorization ( in another layer, same scene) : the image is bigger than preview screen. when i move the picture (space button) the sides of the imported image are lost.


could you please help me ? i don’t know what i can do.

thank you very much

What kind of images are you importing? Are you importing in scanned drawings with peg holes? What are your vectorization options? Are you using optical registration?

If you are using optical registration, the software will automatically line up the peg holes with the bottom of the screen (outside the camera preview box) - is this possibly causing the image to look bigger than the preview screen?

When you hit spacebar, that’s not actually supposed to move the image, that just pans you around your workspace. So I don’t understand what you mean when you say the sides of the imported image are lost. Do you think you could perhaps include a screenshot? Go ahead and upload your screenshot to a free file hosting website and then you can link to it here so that I can take a look at it.


hi lillyV , thank you very much for your help

my images are BMP files. not scanned, created with corelphotopaint. i’m not using other parameters of vectorization than “black and white” already inside animatepro. so i don’t use optical registration.
as you can see :

and result is :

on the second layer, when i import the same image with this way :

it gives the good size inside the work screen :

why do there is a different scaling of the same image when i import with these two kinds of way ?

thanks again lilly for your help

important note : the project resolution has the same size than the image . the resolution of window is under the resolution of the image.
but even when i work on different lower sizes of project, or with the same size of project but with an image in low resolution : it’s always the same : the vectorized image is bigger than the imported.

No problem - I do my best :slight_smile:

So there are two things that I can see going on here. The first is, that your image file is not actually the same size as your scene resolution. From what I can see, it looks like you’re importing an HD image (or, at least, an image that has a different aspect ratio from your scene file) into a standard scene. I.e., it looks like you’re importing a 16:9 file into a 4:3 scene.

When you do this, with vectorisation turned on, it automatically fits the top and bottom of the image to the scene resolution. So, when you vectorise, with your scene it’s fitting the top and bottom but there’s some extra white stuff that comes out the sides - this you don’t see after you vectorise.

When you just do a regular import and plop it into a symbol, it fits it differently by default. In this case, it fits the sides instead of the top and bottom. You can see this very clearly when you look at your screenshot - there is a little bit of distance between the top and bottom of your image file (the white) and the top and bottom of your camera (the grey outline).

What you can do to make this match is you can actually alter the way that the image is fitted in the window with your layer properties. (This is available only in Pro) Now I’ve noticed that when you import, you import into symbols - if you’re going to be doing a lot of images (a sequence) I highly recommend not importing into symbols - or that will make this very tedious. In order to change the alignment, double-click on the drawing layer to bring up the layer properties. Then, in the “Advanced” tab, there is an Alignment section with a dropdown menu. You’ll want to choose “As Is” for it not to fit the image to the window. If you have imported into symbols, in order for this to work, you need to enter the symbol first, then double-click on the bitmap layer inside the symbol - which is why I recommend not working with symbols for this. Or, alternately, you could import into one symbol first, then, to import all your other images, enter the symbol and import from there - without vectorising, you can add the images to the bitmap layer.

There is no way to alter the way that the vectorisation fits the import. It will always fit the top and bottom. If your imported image were truly the same resolution and aspect ratio as the scene file, then both of the imported images would have looked the same.

Sorry this was a little long-winded - hope it helped!


that’s it ! … that’s so simply it !

and i was sure that i had try it to be sure it wasn’t it ???

the project resolution MUST be under ( or egal ) the resolution of windowsxp and the imported image must be under the projection resolution (…or egal).

BUT there is now another question , still on it.

how to be abble to fit the vectorized image in the preview screen ?
windowsxp resolution is 16801050 : the maximum of my screen.
my image resolution is 1920
1080 . the project resolution is HDTV 1920*1080. but the vectorized image is the half !

i’ve gone in the layer properties , as you adviced, and tried “as is” or “center fit” and other options . but it seems it doesn’t work on the vectorized options.

isn’t there a way to fit exactly ? even if i work on a smaller resolution.

thank you very much for your precious help lilly

lilly , there’s something new ::slight_smile:

i’ve pushed space button and this is the result :
the vectorized image is in fact completely imported, but in the original size compared to the windows resolution. is there a way to scale this imported image to fit the preview screen ?


Unfortunately there’s no way to adjust the fit of a vectorised image. It automatically takes the input image and vectorises it, fitting the top and bottom to your camera. Now if the image and your camera (scene settings) are both set to 1920 x 1080, then they should fit exactly.

When you say you want to fit the image in the preview screen, do you mean that you want to see a rendered image of it that you can view in your screen? If you do a render and play, do you see the image at the correct (1920 x 1080) resolution? Do a render and play, then go to View > Reset Zoom - this should show you the image at the actual resolution.


i’ve rendered and tried to view/ reset view : not active but it doesn’t matter because with animation/tools/scale , now i can “fit” (manually) to the preview screen :


now , i hope it will work if i import several images of a complete animation . i mean, with only one movement from first image.

thanks so much lilly :wink:

now wait a moment…

as far as i remember, you don’t have to set the computer image resolution in your animation project to a full hdtv resolution, it’s enough if you maintain the aspect ratio. the computer display (square) pixels are being exported to the (rectangular) video pixels, anyway.
i can recall the graphic display resolution for the hdtv PAL format, being at 1024x576.
correct me anybody if i’m wrong, please, i’m curious about the outcome of this discussion.

When you’re importing and vectorising images and such, the only thing that matters as far as alignment goes is the aspect ratio - so gester you’re correct, you don’t have to have it set to full HD, you only need to make sure that the aspect ratio is the same.

That being said, when you do your final render, you’ll probably want to render at full HD.

I have the standard Animate. When I import a 360 pixel by 360 pixel pdf (Created in Xara Xtreme pro) into a 360x360 project it comes in bigger.
Ideally I would like it to come in at 360X360 but how can I re-size it accurately? I can’t find a way of changing the screen units to pixels. (The project is for a Flash e-card so I kind of need to know that my sizes are accurate.)

I also have TBS 5 and bitmaps and pdf’s seem to import at the correct size. Is this a bug in Animate?
Has anyone got any work arounds. I would like to know that bitmaps imported are exported at 100% in swf’s for interactive work.

I am getting better results. I need to scale the artwork in my vector drawing app which works at 96dpi down to 72 dpi. The imported pdf is still a little too big but just about workable. As I said Studio doesn’t seem to have this problem.

Imported bitmaps must be exactly 72dpi to import correctly.

Speaking of bitmaps. In Flash I use a trick of importing blurred transparent pngs for thing like (in this case) a wing flap. I rotate them a bit and it works pretty well. I’m trying this in Animate. It looks fine in the work area but a bit rough in the Flash export (JPEG compression set to 100) It seems OK in stills.
I guess I’ll have to find a new trick or do that bit in Flash

Do you have the vectorisation options turned on when you import? If so, which vectorisation option is being used? Is it black and white?

If you have vectorisation turned off, what alignment option do you have selected? Is it Fit, Pan, or Project Resolution? Try using Project Resolution - does that get you what you need?

Fit matches the top and bottom
Pan aligns the left side to the left of the camera view and the bottom to the bottom of the camera
Project Resolution is for the bitmap to change according to the scene’s resolution - if you bring a smaller image in it will stretch it to fit, if you bring a larger image in it will squash it to fit

In your case, if your image file is exactly the same as the project resolution, no matter what alignment option you use it should give you the same result.

Perhaps you could send a screenshot of what’s happening for you and we can diagnose exactly what’s going on.

Hi Lilly.
I’m importing my set up as a PDF into the library. My Project is set up as 360 by 360 pix as is the master vector file (Xara Xtreme pro) I import into the library and drag into the work space and it is slightly too big. I can send the files if you like (But off the board please)

Why don’t you go ahead and send an email to techsupport@toonboom.com and there we can set up an ftp where you can send us your files.

Toon Boom Support

Hi Lilly
Thanks. I could even just send them the pdf in the email :slight_smile: which I think I’ll do.

Ive just had a reply from Tech support and a useful one at that!

in the current version of Animate, you can achieve this (Actual size) by double-clicking your Camera element (add one if you do not have one), and in its property window, select the “Override Scene Fov”. (please see attached image).
Note that there will be a new feature in the next version of Animate which allows you to change the field of view (fov), so that your image fits the camera.

Thank you for your patience Dave I’m glad that we were able to resolve this issue for you.

Toon Boom Support