Using a bitmap as reference

Well, With all the trouble importing pdf’s I decided to try and import a bitmap reference image to work over so I have once again run into problems.
Bitmaps don’t work with the light table and vectorizing them doesn’t really work as the bitmap bits stay as bitmap textures.

I am stumped as how to do this. I’m guessing I’m missing something obvious as you would be unable to match animation to photo plates or video ref otherwise.

Can someone please put me out of my misery?

A nice cup of tea did the trick. I re-started Animate and now I’m seeing the bitmaps in the light table view. Not sure what, if anything changed there but I’m glad its working now.

Gone again. Bitmaps and imported pdf’s are just not showing up in the drawing view with the light table on. If i draw on a layer that shows up :frowning:

Any one have any hints or tips?

Using Animate PLE 7.6.0 / OSX 10.6.2

Well, I never managed to see any bitmap images (PSD) in Drawing view,
with or without Light Table activated… not even vectorized…
I always thought that how it is in Animate… or a limitation of the PLE…
So, I switched back to Camera view for reference…
(this feature works of course beautifully in Studio)

How did you manage to make bitmaps visible in drawing view…?
(what nice cup of tea did you had…? a magic brew… :slight_smile:

Sorry, can’t offer any hints or tips…


I’m not seeing it in Pro but perhaps I’ve misunderstood the problem.

I imported a Quicktime movie (volcano2).

I added a drawing layer above the movie layer (native).

I activated the light table in the drawing view and the onion skin for the (native) drawing layer and drew a few frames.

I also tried it with psd layers which also worked for me.

Right. I think I’m a little further ahead. It seems that the light table will only work if onion skins are turned on…kind of.
Here are 2 screenshots:
Camera View
Int the camera view all is fine and dandy.

Drawing View

WTF???. Animate is showing all the layers even though most of them are turned off and the bitmaps are the wrong size. This is aside from the fact that I don’t want the onion skins on.

As a test I have been trying to do simple stuff in Animate and time and again I keep hitting stuff like this. I am really starting to regret paying good money for it. I know that there is a paid update soon but I really think that all the bug fixes should be free and the software working as advertised before we shell out.
Actually as Kongbot doesn’t seem to be having this issue maybe it works in the Pro version. Though with my experiences recently and the price I am very unlikely to upgrade.

Right. I’m off to have some tea (Peppermint) and to calm down


Please note that this does not happen in my test setting.
To verify what is causing this for you, we would need to verify the specific project.

Please reply to the support email response I sent you and once testing is complete;
we can post our results in this forum thread to keep other users informed.

Support Specialist
Toon Boom Animation Inc.

Thanks Debbie. Will do. I’m hoping that it is specific to my setup.

Hello Dave,

I just wanted to clear something up regarding this issue that I believe Debbie has already responded to you on but for the benefit of the others in the forums. The problem with showing an imported bitmap in the drawing view is that with Animate, when you import a bitmap, it automatically sticks that bitmap into a symbol. Symbols cannot be viewed in the drawing view. For this reason, when you import images, you should work from the camera view instead of the drawing view.

In Animate 2, we will be giving the option of whether or not you want the imported image to be encapsulated in a symbol. There will also be more options regarding image import than there are in Animate 1 - so stay tuned for those.

Regarding the Onion Skin issue, you most likely have the following preference activated: Edit > Preferences > Drawing Tab > Enable Onion Skin for Other Layers. This will show the onion skin of your other layers, regardless of whether they are turned on or not. Please uncheck this option and you should not have this problem anymore.

Hope this helps.

Toon Boom Support

Hi Lilly:
The symbols issue is a bug as far as I can see. Can this be fixed in V2?
I am still talking to Debbie regarding the light table issue that seems somewhat deeper than just the symbol issue. I will report back when there is a resolution.

Onion skin - Really this is just a hack to get anything displayed in drawing view and generally I do not have a problem with it. However, I can see no point at all in the ‘Enable onionskin on all layers’ if it doesn’t respect the visibility status of the layers. Especially as it is a global setting that has to be turned on in preferences. Can this too be fixed in version 2 please.

Symbols not being shown in the drawing view is not a bug and will not be fixed in Version 2. This is not something that can be “fixed” - it’s to do with the way that our software is designed. For working with symbols you will have to make use of the camera view. The drawing view is for drawings, the camera view is for symbols and animation.

I verified the preference - the odd thing is, the preference works as you would expect that it should, in fact. When I did a test on a fresh scene, I found that when I had the preference enabled, it would only show the layers that were enabled in the onion skin in the drawing view. So then I had to do a bit more digging. When I was investigating with your scene, I noticed that when I had both the timeline and the xsheet open, and I disabled a couple of those layers from the timeline, they did not disappear from the xsheet as well, as they should have. This seems like it was what was actually causing the problem.

I was able to turn on and turn off the layers correctly when doing it from the xhseet. In the xsheet tab, there’s a little triangle on the right hand side that points to the left. Hit this triangle twice until you get a layer list with checkboxes in it, and turn on and off your layers from here. Make sure that the layers that you don’t want to see in the onion skin aren’t visible in the xsheet. Now does this fix your onion skinning issue?

The interaction between the xsheet and the timeline is much more robust in Animate 2. There would never be a situation that would occur in which the timeline became disconnected from the xhseet in this fashion.

Toon Boom Animation

Sorry Lilly, ‘Bug’ was a bad choice of words on my behalf. Rather this feature doesn’t work as expected and should be explained.
When I have the light table, onion skin all layers preference and Onion skins turned on I do actually see the bitmaps and imported PDF images do display but are the wrong size and are out of position (I did a demo movie for Debbie) It really does look as if it should work.

Is there a way of breaking apart a symbol in the time line so that it displays on the light table? I can’t find any reference to this in the docs but it might solve my problems?

AH. The little triangle. I clicked it once before and only got an got an empty box so promptly forgot about it. Twice does the trick and works as you observed. It is pretty well hidden though.

Huge Regards

The empty box will show the function columns for the selected layer, so if you have a layer selected and you have keyframes on that layer, the middle box will show the function layers there.

There is a way indeed to get the contents out of a symbol. Select the cell that contains the symbol in the timeline and go to Edit > Expand symbol. This will create a new layer that has the contents of the symbol and if you like you can even delete the original layer. Just make sure to unparent the new layer from the original before deleting the original.

Toon Boom Support

I was nearly very excited there. Breaking the symbol does indeed make it appear in the light table view. Sadly though it displays at the wrong size. :frowning: