Updating Bitmaps

I’m working with a raster JPG background in a shot. Ive successfully imported it, added a camera move to it and everything is working great.

Now I want to make a change to the original JPG (in Photoshop). Will I be able to “update” the bitmap image like I could in Flash, or do I have to import from scratch and redo my camera move?


To do so you will have to put your image inside a Media Element. The Media element are actually external links so if you actually replace the source file (in the folder of the projects under Scenename/Bitmaps) this will automatically replace the image in your projects.

Best regards,


First off, don’t use jpgs. They degrade in quality every time you edit them because they are compressed. Go with tiff, bmp, or tga formats. :slight_smile:

How about PNG?

I’ve been reading the TBS help files about media elements. It tells me four different ways of making a media layer, but I can’t find how to add/link my image file to that layer. Importing doesn’t work, because the image shows up on a totally new image layer.

I have been trying to follow your suggestions here, but to no avail. The linking to media elements works for templates that are drawing elements OK but bitmaps seem to be different. I tried the replacing the bit map image for the file in the scenes bitmap folder but was not successful. So the question becomes:“How does one link a bit mapped image to a TBS animation project so that edits to that bit mapped image are reflected in the final rendered movie output by TBS?” Thanks -JK

Hi JK,

It seem you are right, for the moment the image element only refreshes when you restart the application. This rule is applicable for both the actual bitmaps in the Element folders and the Templates.

I will report this to the development team for this should be working properly. I am sorry for the missinformation, I had tested it with drawing and was expected the same from bitmaps.



I still don’t understand this. How do I put a TGA or other bitmap on a media element? Import doesn’t work. Paste is not allowed.

Well, first of all it might be a good idea to create a Media-Folder or Catalog
in your Global-Library.

Select that Folder / right-click and from the Contextual-Menu choose Import
Image File… or Movie-File…(SWF).

In the Exposure-Sheet create a Media-Element and drag your Image-File or
Movie-File from the Library into that Media-Element.


Okay, that should help. I haven’t researched and utilized libraries yet. I guess that’s my next step.

Okay, I managed to set-up my library, import files, and put them in media elements.

Now back to my initial question. When I change the original TGA files on my hard drive, they don’t update in Toonboom.

I right-click on the file in the library and hit refresh, then restart the program. Still no change.

Using Toon Boom Studio 3.5 / OSX 10.4.9

Well, save your image into your Global-Library and drag that image from there
into the Media-Element in the Exposure-Sheet.

Your image will be saved into the “Toonboom Studio-Global Library 3.5” folder,
this one resides at my place in the Documents-Folder.
(your original might still reside somewhere else)

Open Photoshop or any other image-processing-software and load that image from the Library-Folder and apply a filter or any other adjustments to it.

Save everything and restart Toon Boom Studio / your image will be updated.
(works fine here)


Thank you thank you!

I had no idea that the linked files were actually copied first into a folder in My Documents. I thought I just had to replace the original ones I had imported to begin with.

Is there a way in preferences to change the location of the global library? I’d rather not have it on the C-drive of my computer. I keep all my job projects on the D. I’d be afraid to miss the global area when I back things up.

Look on the General tab of the Preferences panel. It will let you point to a new Global Library on a different path. So if you copy your current global library and paste it onto your desired drive and directory path and then redirect TBS from the Preferences panel that should get you set up. Hope this helps -JK