Unwanted Keyframes when Drag&Drop in the timeline

Hello Everybody

I have a question regarding Drag&Drop and Keyframes. Everytime I move a section in the timeline it adds a keyframe on the first frame of the section. If I move / drag&drop a whole group it adds a keyframe on every single layer. (See attached Image). Under preferences/ camera the “Paste/ Drag & Drop adds keyframes at beginning and end” is disabled. In fact enabling and disabling of this preference doesn’t change anything.

Am I doing something wrong here or is this a bug of Harmony?

Best, Nils

(Toon Boom Harmony 14.0 on MacOS 10.12.3)

The older versions of Animate Pro, Harmony, and Digital pro didn’t do this. It just happened in one of the newer versions and it’s super annoying!!!
I’m not sure how to fix it. But I would love to know if there’s a way.

Go into the Timeline window’s Menu-Edit-Modify Paste Presets
By default choose All… and in the “Edit Default Paste Preset” window
uncheck “Add/Remove Keyframes”

You can also check the Menu-Edit-Modify Paste Presets
Keyframe… or Exposure… settings. These settings are only
used if they have been modified previously otherwise the
behavior defaults to what has been set in the All… window.

hello rkriz

thanks for taking the time to answer! unfortunately your solution doesn’t work out for me. when I go to “timeline-menu/ edit/ modify paste presets” there’s only “keyframe” and “exposure”. I don’t know what you mean by the “All…” window. And if I uncheck the “Add/Remove Keyframes” under “timeline-menu/ edit/ modify paste presets/ keyframe (and exposure” I still have the same problem with the unwanted keyframes when drag&dropping. Do you know what I am doing wrong?

best, nils

(harmony premium 14.0.0 / mac os 10.12.4)

Hello, it’s me again! Those unwanted Keyframes are really annoying. Is there really no solution? It’s especially frustrating because there is a preference regarding this very issue, but this preference doesn’t change anything…

I use Harmony Advanced.

Among the buttons above the timeline there are 3 at the end.

  1. white square with lines
  2. small square
  3. looks like 3 but no lines

By default 3 is selected which means when you drag frames there will be keys added.
If you select 3 you can drag/ move frames in the timeline and no keys are added.
if you select 2 you drag keys no frames.

That how it works here at least.

In the timeline windows menu:
Edit-Modify Paste Presets-All…
I thought you would understand from the context
of what I was explaining.

Do you mean Paste Mode: All Drawing Attributes, Paste Mode: Keyframes Only and Paste Mode: Exposures Only?

http://docs.toonboom.com/help/harmony-14/advanced/reference/toolbar/view/timeline-view-toolbar.html?Highlight=timeline%20toolbar

The timeline toolbar icon “Paste Mode: Exposures Only” should stop
the unwanted keyframe creation.

This menu just pass unnoticed by our animators, the timeline menu cited here is the “three lines” button you see at the top left side of the timeline. Once you click on it, you see the “all” option and then just follow the solution sent by RKRIZ up there in the beginning of this thread.

Hello everyone. Here is a tip to make this make sense and clarify things.

1.) Go to the Timeline’s menu (In it’s own window) and go to Edit-Modify Paste Presets- and then either or all of the submenus- All, Exposures, Key Frame depending on what method of Drag and Drop you are currently using.

2.) Deselect "Force Keyframes at Function’s Beginning and End

This will allow you to move grouped keyframes without creating extra superfluous ones - Extra useful when changing timings of rigged puppets!