Undoing commands does not reveal the affected drawing - very frustrating

This is by far one of the worst nightmares of an animator - Harmony is not showing the actual affected drawing when Undoing commands. So there is basically no way to know what I am actually undoing! There is also no History panel, so no way to see where I am. The UNDO menu in the Editing module does offer a list of all the recent actions, but it is impossible to understand at where I am anyway, since I cannot see the results on the screen anyway. I tried the setting “Restore Current Selected Drawing on Undo” but it didn’t do anything - I am also not sure what it does…
Is there any way to optimize this? Or just forget the undo command like in the good old paper days?

UPD: Here is the video that describes exactly the problem: https://youtu.be/KxXLuk7oOwU

It is basic linear Undo.

Every step taken is undone in the reverse order it was done.

Layers do not have separate undo capability.

You cannot jump across steps and undo a step retaining steps that followed that step.

So, if you last worked on a different layer 10 steps earlier and switch back to that layer you will still have to Undo all the steps which followed the last step made on that layer before you can undo that step.

As for knowing where you are at any given point, whatever is highlighted (i.e. the specific layer, node, View, etc. ) is where you are. Because Undo is linear you have to be mindful of what you just added when you consider what to Undo.

While there is room for improvement, it is simple because the Undo feature is so basic. Anything beyond simple is not built into the Undo feature.


This is absolutely not what I’m asking. The problem is that when I undo a command, Toon Boom doesn’t actually show anything on screen. To be precise - it doesn’t automatically jump to the place in timeline, where an undo command is taking place. How can I know what I am undoing, if I don’t see it? any sane program would show me what I am undoing.
Example: I draw 1 line on frame 1, and then another line on frame 2. I am now on frame 2. I undo once - I see the undo happening on frame 2. I undo second time - bam, I don’t see it happen, because the timeline still stays showing me frame 2, instead of jumping to frame 1 and displaying the undone command!

What software automatically shows what is undone and you don’t have to make sure the target step is in view yourself.?

What software allows you to undo something buried multiple steps deep without undoing everything that came after that step?

I gave you an extra detailed explanation. I figured you could make a logical deduction from the information I presented and apply it to your past and future experiences.

You still expect too much of this implementation of Undo.

You cannot “jump to a place” I clearly spelled that out to you when I said you cannot jump across steps.

It is linear not spatial. If you cannot comprehend these concepts the problem is not in the software it is in your ability to understand the feature’s limitations and consequences of those limitations.

I suggest you look up the words linear and spatial, set your frustrated mindset aside and take time to think about the definitions.

dude, I think you should stop commenting on my questions because instead of understanding what I am asking, you are just trying very rudely to be a smart-ass and patronize me.
I have more than 20 years of experience with most of the 2D software on the market - animating, teaching animators and supervising productions.
I don’t think I need to explain to you how Undo works (by the way, for non linear undo - check Photoshop, you will be surprised).
If you want to be helpful, and confirm this bug, you are welcome to read the initial question again. If you have nothing useful to say, you are always welcome to pass on you next neck-bearding attempt

You already pointed out how there is no listing of action history in Toon Boom Harmony so referring to Photoshop only demonstrates how you don’t comprehend the concept of basic linear undo.

Look up the word “basic.” Linear can be simple and basic and it can also come with more features like a visible accessible action history but Harmony is at the most basic end of the spectrum. You still expect more and insist there has to be more so in your mind it has to be a bug. 20 years experience with software doesn’t do anything for your stubborn personality.

Good luck.

Hi guys,

In any way of understanding well or not, this might be what you are looking for.
Also add a bit more of undo actions in the genearal tab of the preferences panel.

Hope it helps


Ok, to avoid further unnecessary arguments, here is a video, that shows exactly the problem:

The stubbornness with which you are so unwilling to read and understand my initial post is admirable! Out of admiration and to save you time and effort I have recorded a video of the problem that will hopefully put an end to this pointless argument. If this video still somehow demonstrates my inability to understand the basic concept of linear undo, I might start believing that the Earth is flat:

having more levels of Undo doesn’t solve the issue, just add more confusion actually :slight_smile: . also the setting in the second pic doesn’t do anything - I already described it in the initial post. I have recorded a video to show what the problem is exactly (in the commend below)

Thank you for this revelation! So if I work in the Drawing view it all works fine, but doesn’t function if I work in Camera view. Which means I need to remember to switch to Drawing view before starting to work on animation. Not the best workaround though, because I often need to see the active layer in relation to other layers, but it is better than nothing for now. It would be really helpful if you implement it in the next release for Camera view too!

Hi Soom,

Okay, so I think I found it out.
See the attached video. https://fileshare.toonboom.com/wl/?id=x3eRTg6t9wqq0NkyPUxToQaAEBs3yQmr

This option is only available for the drawing view. Not only when undoing in the drawing view after having drawn in the camera view, but ONLY if you drew in the drawing view,
I think it might be possible to make it work in the camera view as well.

Thanks for reporting this behavior, we’ll try to adapt it in a further version.

Hope it makes sense.

Best regards