undo when editing symbols.

When i create a symbol and drag it back into my scene and double click in to edit it and add new drawing the undo doesn’t appear to work.

Is this meant to happen? (i accidently dragged the paint tool over the head and made it all one colour and couldn’t undo, lucky i like to save :smiley: )

I have never noticed this before because I usually set everything up perfectly before converting to symbols but I have decieded to edit a few things on the fly quickly and having no undo is a huge hinderance.

I can’t belive it is meant to work this way, so I figure i must being doing something.

It my method of editing wrong, or is there a setting a need to enable?

I tried to reproduce your workflow based on your description, and I wasn’t able to reproduce the problem.

Are you able to consistently make this happen? If so, what are the exact steps you follow to make this happen? Can you make it happen from a brand new scene?

When it does happen, what do you see in your undo list? To see the undo list, click just to the right of the undo button, there’s a little triangle, and if you click on this, you will see a list of the undo actions. Do you see the last action that you performed in this list?


I will test again later tonight.

I was so annoyed at the time cause it was basically unuseable without an undo that I figured it was just a setting.

I will do it again and make sure it is still happening.

it is just that one symbol. I tested other symbols in the scene, and in new scenes and couldn’t reproduce it(although it still didn’t work in the one that gives me problems).

I have no idea why it is doing it.

However i fixed it by deleting the symbol and reimporting it and now it works fine.

Why don’t you contact tech support directly, techsupport@toonboom.com. There we can set up an ftp where you can upload your scene so that we can take a look at it and see exactly what’s going on.

Toon Boom Support

Like i said now I deleted the symbol and redragged into the scene it is fine.

So you guys would be chasing ghosts since it now works :slight_smile:

I probably would of fixed it myself but at the time i posted it i was tired and annoyed because I knew it wasn’t meant to be doing that ;D

Sorry indeed for the inconvenience - it would have been nice to see the file because we have had more than one report of this problem happening, but have never been able to reproduce it on our end.

In any case, very happy your problem has been resolved!

Toon Boom Support

That actually makes me feel better that it wasn’t just me.

If it happens again I will save and send it to support.

Thank you very much!


happened again and sent to support.

Good luck.