Unable to insert keyframes.

Hello.
I am following a course by Tony Ross, ‘Learning Toon Boom Harmony essentials’, which includes a lesson ‘Setting Up a Master Peg’, which shows how to insert keyframes into each layer of the first frame, when the layers are collapsed into the Peg layer.

I am finding that whatever I try, i can only insert a keyframe into the top (Peg) layer, and no keyframe dots appears in any of the other layers. even when I try to insert a keyframe into individual layers, nothing seems to happen. Also, I notice that the ’ add keyframe’ button above the timeline is greyed out after I insert a keyframe into the top layer.

Does anyone have any advice.?

Thanks for any help.

Open the Harmony Preferences window / Advanced.
Select Elements Node “Animate using Animation Tools”
This effect will take place for all newly created layers.

For all already created layers… Open the Layer Properties Panel and select
“Animate Using Animation Tools”

This will make sure, all sub-layers in collapsed Master-Pegs will receive keyframes

http://docs.toonboom.com/help/harmony-12-2/advanced/rigging/disable-animation.html

Thanks Nolan for your helpful response.