Unable to import Illustrator file into Toon Boom

Hello everyone!

I am trying to import an Illustrator file into Toon Boom Harmony 2015. So far I have successfully uploaded the .ai file to the Harmony Premium Library, but every time I drag it into my timeline or a Drawing Layer nothing happens and both stay empty. I have tried this procedure with my file saved as a CS, CS2, CS6 and CC Illustrator document, as well as converting it to a PDF (always using RGB colours) but nothing will work, not even Thumbnails can be generated.
Also, every time I select “Edit Template” this message comes up “Template H:/Documents/Toon Boom Harmony Premium Library/Untitled.tpl is an older style harmony template and cannot be edited.”

After restarting my computer (an hp) and still having the same problem I have no idea what else to do.

If anybody thinks they can help I would really appreciate it! :slight_smile:

First make sure that the illustrator file name contains no accented letters,
special symbols or spaces. Only use a-z, 0-9, “-” and “_” for file names.
This rule also apples to every folder name in the path you are importing the
file from. Beyond that…

Try saving the Illustrator file to be compatible with Illustrator V10 (pre-CS)
which is the last version where Adobe made the methods of Illustrator public.
Newer features will not be understood if used.

Thank you for your message, I have done what you suggested but unfortunately it is still not working.

Can you think of anything else I might be overlooking?

Hi rkriz, I’m 3milia’s tutor, it is Harmony Premium 15 we are using and not Toon Boom Harmony 2015. So the (nearly) latest version of Harmony and the latest version of Adobe. Is this a common problem?

I would be happy to have a look at your file and see if I am able to import it?

I’ve uploaded a video explaining how I import my Illustrator files into Harmony with separate layers: https://youtu.be/9_hvZ0mNXMM

I am using the latest version of both programs (Illustrator V23 2019 and Harmony Premium V16), but I’ve been using this method for years and haven’t had a problem yet.

If you watch the video, please let me know if this works for you AND if it doesn’t work. I work on a Mac, I would be interested to see if it’s a Windows issue?

Fingers crossed!