Unable to draw pictures on multi-plane. Drawings disappear~!

Having a little (Actually, gigantic) problem here. I’ve went and created this background in 3d using the multiplane (No meshes, just 2d images rotated to seem like 3d cubes). However, when I try to do 2d-animation over it, like a character running up a building with the camera following, The drawing is not shown. In fact, it’s shown below the 3d background, even though the 2d layer is above the 3d one.

As you can see here: https://s28.postimg.org/r9cgrzp7h/image.jpg
— It draws on top of everything before I let go of the button.

Then you see here: https://s23.postimg.org/yz15561nf/image.jpg
— It disappears once I let go of the cursor.

Any advice on how I can make this stop? I’ve tried with and without ortho-lock, I’ve tried closing the program, I’ve tried restarting my computer, and I’ve tried adjusting the Z position on both the BG and thedrawing layer; still no luck. PLEASE help me, and if you can’t, ask a buddy if he/she can! Thanks~~~~

Hey alohalmfao!

Any chance we could get a peek at the top/side view to see where that layer falls? :slight_smile: