Trouble Exporting: Shared Memory?

Hi all,

I am having trouble exporting–whenever I try, I get this popup window saying “Frame unable to create shared memory segment, error : QSharedMemory::create: out of resources.” However, I have restarted my computer multiple times and have NO other applications running, so it’s impossible that it’s another program using Shared Memory.

It’s basically the problem discussed in this thread:
I know people have had this problem before, but I think I’ve tried all the solutions suggested and it still won’t export. Any advice would be greatly appreciated!!

Thank you~

I’m having the very same problem. I’ve tried setting the compression to Animation and H.264 yet every time, regardless of what project I’m exporting, I get that same god awful error message.

I am just thinking of things that I would try as an experiment. I cannot create this situation to test before suggesting ideas. Sometimes running out of memory can be alleviated by setting up a scratch disk but this software does not offer that option.

I am not sure whether it is involved when rendering a movie but I would try setting up the Image Disk Caching option. This offloads rendered images immediately to the disk, I guess instead of creating a memory ravaging file held in RAM, utilizing more storage memory and less RAM during the process.

Preferences => Render => Image Management =>

  1. Check the box to “Enable Image Disk Caching”
  2. Type in the path to the hard drive space you will use as the cache followed by a colon and the amount of space you are allocating to the cache in terms of MB. (1gb = 1000mb)


file: /// Users/ name of your computer /Desktop/ name of a folder created to contain the cache data :5000mb

(Ignore the spaces in this example. The forum software wants to make live links if it sees text that looks like a URL)

You must be using Animate and not Animate Pro.

I had followed the links in the other threads referenced here which also referenced another similar problem thread and in all of this that original thread was discussing Animate Pro 3.

The option is not available in Animate.

I don’t see any “Image Management” tab/text under the Render tab. All I see is Enable Line Texture, Enable Blur, and Enable External Read.

No, I don’t know how to do that. Should I do that?

Do you really mean every time as in all projects or do you mean every time you attempt to export with one specific project?

Someone brought up the use of large bitmaps as a possible trigger in some cases. What is your project comprised of?

Yes, every project :frowning: I even deleted the bitmap layers/everything but the vector drawing layers, to see if that was the problem.

Animate doesn’t appear to have a scratch disk option.

Do you have Image Disk Caching set up in Preferences?


I’m working on harmony 10.0.1 and I have the same issue when exporting (“Frame unable to create shared memory segment, error : QSharedMemory::create: out of resources”).The problem appears when I place a background in my project. Even when that background is one jpg layer. I’ve tried every suggested method without any result. When exporting juste one animated character, the export goes well. I have tried exporting with other codecs, smaller formats, smaller projects, through render network and nothing. I also quit every other application and restart the computer, it didn’t help.

I tried to make a cache folder, but there was another problem: When restarting Stage it says it can’t find the folder, a wrong trajectory issue it seems. But i’m pretty sure I write it well (I paste it).

I’ll be grateful for any help. Thanks!

What are the pixel by pixel (width and height) dimensions of your background?

Do you have any other application running att the same time? E.g. Adobe Illustrator or Sophos Antivirus?

If you’re getting this error it can be caused by one or several of the following…

  • Heavy use of texture pen
  • Project is too long for your system’s resources
  • Trying to export to too high a resolution
  • Too many high resolution bitmaps imported into the project or some that are unreasonably large (high res)

First try optimizing the project (i.e. flatten and remove unused files).
Try exporting to HD format or smaller as a test (do you still get the error?)
If all else fails, try splitting the board into separate projects (acts perhaps?)
and re-combine the animatic using an editing software.

Check if e.g. Adobe Illustrator is running at the same time you are trying to export.
I had the same problem when I exported QT as 1920 x 1080. Closing Illustrator solved my problem.