Transparent images

I’ve had to create another thread as I cannot find my one I made last night :confused:

How do i render my animation as images with no background(Transparent) I set the render to PNG but once the images have rendered they have a black background.

Did you choose millions of colors + in the options of the PNG?

I’m a newbie to animation and I just want to double check if I’m doing the right thing.

I would like to export a line drawing animation with a transparent background, so I can use it in Final Cut Pro X as an overlay on top of live footage.

I’ve searched the forums and the web and tried out all of the suggestions.
The closest one to get this to work is to export it as an Image Sequence, set the options to PNG and Million colors+, just like a few of you suggested. I end up with a huge amount of .png files.
I imported them into FCPX and set the Duration to 1 frame.
This creates the effect I’m aiming for.

But it feels like too many steps (importing all the .png’s and basically recreating the sequence that I already created in ToonBoom).
So my question is: is this the only way to create this? Do all the other export options generate an opaque background?
I guess I could also finish the live footage and import it into ToonBoomStudio6 and add my line drawings as a layer.

Can somebody shed some light on this?
Thanks in advance

Well, it’s all in the codec you’re using… and of course your personal preference…

There’s really nothing detrimental using image sequences… (PSD, PNG, TIF, TGA).
Single images, or small sequences can be re-rendered at any time…
(specially very important if the render-process get interrupted)

If you like, you might prefer to assemble those image sequences
with QuickTime Pro 7 (or else) before importing those into Final Cut Pro X…

Otherwise, export your projects as QuickTime Movie…
Try Animation with Millions of Colours+ (not sure if Studio renders ProRes 4444…?).
Or any other codec you have that supports alpha channels (transparent backgrounds)…


Hi Nolan,

Thanks for your help. I played with it and exporting to QT works.
I had played with it before but after importing the QT movie into FCPX it appeared black, so I didn’t even bother to put the green screen under it because I thought it hadn’t worked.
Stupid me.
I animated an expanding black circle. But black on black isn’t visible until you mix it with a background (green screen clip). So it did work in the first place.

Thanks again. This helped a lot!!