I just downloaded TBS.

Everytime I try to use the Transform Tool it doesn’t not work properly. I will select an element, then I will chose the transform tool, when I click on the element to move it, the transform tool is deselected. The only way I can move an element with the transform tool is by using the arrow keys and that is a very very slow process. Why is the transform tool deactived after I click the element? How do I fix this problem?


Switch your Viewport to “Camera View” and it should work fine.

Otherwise, please try this…

Draw a colour-filled-circle (or else) / switch to Camera-View /
move the time-slider to frame 100 (or else).

In the Timeline Right-Click the first frame and choose Exposure / Extend Exposure /
move your time-slider to frame 20 (or else) / select the Drawing-Element in the Timeline.

Select the Transform Tool (7) / in the Viewport move your drawing to another position /
move your time-slider to frame 50 (or else) / in the viewport move your drawing again /

in the Timeline you should see two Transform-Keyframes connected by a black line /
go on and set more keyframes if you like / click the Play button.

Try moving the drawing by Shift-clicking the Arrow-keys.


I tried you suggestions.

The transform tool still does not work with the mouse.

After selecting the transform tool then trying to select an element the transform tool is deactivated. It only lets me draw a box around the element, but there are no handles to move it. The only way I can move an element is with the arrows.

Thanks for any responses.

I believe your problem is due to the fact that you currently have “peg only mode” enabled. The menu selection is Tool>Turn Peg Only Mode Off or you can press the “M” keyboard short cut. This should solve your issue. -JK

I tried making sure that the Peg Only Mode is OFF, that does not work either.

I am in the camera view. I select the element I want to animate. I have the element on for 20 frames. The marker is at frame one with the element selected. I click on the select tool in the camera view and click on the element. I get a box with handles and I can move the element wherever I want. Then I click on the transform tool. As soon as the mouse button is clicked in the item becomes unselected.

Once again the only way I can move an element with the transform tool is with the arrow keys. Please help. As of right now this software is useless to me.

Thanks for your help.

Does this element have a lot of empty space inside the selection rectangle and the transform rectangle and if so when you click to move the element are you clicking on the actual drawing or just inside the rectangle in the empty space. If you are clicking in the empty space that would cause the item to be deselected but if you click on the actual drawing you should see a 4 way arrow icon. I can duplicate your described problem with Peg Only Mode ON or by clicking on empty space. But otherwise it beats me what you are doing, it isn’t the software. You said you just downloaded the software, so I have to ask the really stupid question is this V3.5 of Toon Boom Studio or did you download something else like V3.0? Sorry I’m tapped out with advice on this one. -JK