Toon Boom Harmony Premiun 2021: Tools Not Operational

Hi!

I am a beginner to Toon Boom Harmony. In fact, when I created a new scene, I am able to grab tools from the toolbar on the left, though the problem is whenever I draw a line, for instance, that line disappears after I let go of the mouse, and the similar problem applies for every tool, such as the text box. I would like to let you all know that I have not touched anything else (it is at default settings).

I hope I am describing this problem properly, and I look forward to any advice and support offered by you all.

Thanks!

OS version you are on would be nice to know? Are you using Harmony 21.1? Where are you saving your project folder, do you have read/write access?

Hi!

I am using Windows 10 Home and I believe I am using the 21.1 version of the software. I have saved my sample project in my “Documents” folder. How can I check if I have enabled read/write access on this software?

Please let me know if you would like for me to send pictures of the problem (if it would help).

I have heard of the issue before but not seen a reply to a fix/solved for it. So I’m just going off the top of my head with ideas to try out.

When I asked about read/write access it was to see if you were saving in an odd location but the Documents folder should be fine.

Are you using a desktop or laptop, what type of GPU (video card) does it have?

With Harmony closed try deleting the Layout and Preferences folders in this location.
C:\Users\[username]\AppData\Roaming\Toon Boom Animation\Toon Boom Harmony Premium\
On Windows, the AppData folder is hidden. To display it in Explorer, in the top menu, open the View pane and check the Hidden Items checkbox.
Then open Harmony make a new project and test out drawing.

Hi,

If it helps, I am using a Dell XPS 15 7590 (a laptop), and the GPU that I believe the laptop has is a Nvidia (GeForce) - I don’t know the exact type as of yet.

I shall try this idea out. I will let you know soon if anything changes.

Thanks!

Make sure Harmony is using your Nvidia GPU. You can change which programs activate it in the Nvidia control panel.

1 Like

I will see what I can do with this.

Meanwhile, I apologise in advance if this is too much to ask, but I have recently found another problem, which I believe links closely to performance (by the GPU). This problems is basically whenever I enter composition mode on Harmony 21, the program crashes (i.e. it shuts down immediately).

I don’t know if these two problems are connected in any way, but I thought it would be informative for you to know this.

Yet again, thank you for your advice…

Just to let you know that I have a NVIDIA GeForce GTX 1650. Thought it may help you out.

I would like to update you on what I am doing to resolve this issue: as you said, I shall delete the respective folder mentioned, but I cannot find it in this location. All I get is the following (shown on the screenshot):

I want to make sure that I am doing this properly, so please let me know if these folders should be deleted.

Thanks!

Correct those are the two folders.
But first make sure Harmony is using your Nvidia GPU. Here is info/link on customizing you Nvidia Control Panel.
https://nvidia.custhelp.com/app/answers/detail/a_id/2615/~/how-do-i-customize-optimus-profiles-and-settings%3F

Also in you have no reason to use Harmony 21 you should look at upgrading to Harmony 22.

1 Like

I have deleted those two folders, and I have opened Harmony 21. The results is the same - with the drawing not fully functional, nor are the tools. I have also followed that guide to ensure NVIDIA is linked to Harmony whilst it is running, yet nothing different occurs.

How would I be able to upgrade to Harmony 22 from Harmony 21?

Thanks!

Maybe try running Harmony as administrator (right click shortcut)?

Log into your Toon Boom account on the main site and check downloads for Harmony 22.

I already tried that, yet it still don’t work…

Try contacting support and see what they say?

Sorry I couldn’t be of more help, best of luck.

That’s all right.

Thank you for your advice and help. I highly appreciate it.

1 Like

Hi @steenbeck, I presume you would like a brief update on this situation: after reinstalling the software, that issue got fixed…

So, all in all, I am glad you provided advice and assistance to this matter.

Thank you.

1 Like

Thanks for the update @S_Mni2LliP_11 glad to hear you are up and running!