Toon Boom Harmony Essentials 21: Anti-Aliasing Not Working Right?

I’ve been using Harmony Essentials for over a year now, but recently I reinstalled my PC (moved from an SSD to an M.2 drive), and ever since I reinstalled Harmony, I started noticing jagged, non-antialiased outlines for the drawings on the canvas. I don’t know whether it actually did this before and I just never realized it, or if some setting I have on this fresh install of the program or W10 is in fact causing it to behave differently.

I really don’t remember outlines from the Stroke tool, for example, being so jagged (they look like they’ve been drawn with the pencil tool in MS Paint). If my memory serves correctly, they looked smooth (like you’d see for the Pencil tool in Adobe Animate, for reference). And, although the brush strokes look fine when the video isn’t playing, when you do play it, all of the antialiasing seems to shut off and all of the drawings on the canvas look gritty and pixely, and it gets much worse the further you zoom out.

I have the “Full Scene Antialiasing” turned on and currently set to 16 in the OpenGL settings within the Preferences. Again, this does apply antialiasing to the brush stokes on the canvas when the timeline is not playing. However, again, as soon as hit play, the antialiasing seems to vanish. I don’t know if there is a setting I need to change anywhere in Harmony or in Windows? Or is the program in fact meant to behave this way in OpenGL mode?


This is a known issue with Harmony 21.1 upgrade to 22.

  • Lines are not Anti-aliased during playback. HAR-8262

Thank you for the response.

I downloaded an ran the trial for Harmony 22 Essentials but it is also having the exact same issue.

After looking around some more, I found out that it may have something to do with the “Enable Playback Caching” option that is allegedly in the OpenGL preferences, however, neither my versions of 21 or 22 have this.

Do I need to upgrade to a version that is beyond “Essentials” in order to have playback antialiasing? Thanks.

I believe I have figured out the issue. Apparently this lack of playback antialiasing has always been in the version of Harmony I’ve been using but I just noticed it recently, so I don’t believe it was a setting I changed.

I tried both Harmony 22 Essentials as well as Advanced, and although Essentials also does not have the “Enable Playback Caching” option in the OpenGL settings, Advanced does. And unchecking that instantly solved the problem.

I wish even just this one feature was available in Essentials. It’s one of the few things I would find useful in the Advanced and Premium versions of Harmony, but I don’t feel like spending a grand just for it alone. :woman_shrugging:

THERE IS A FIX TO THIS! I contacted the Toon Boom development team and they gave me a solution, and though it involves editing an XML document in the AppData, it worked like a charm.

I headed on over to:
C:\Users\UserName\AppData\Roaming\Toon Boom Animation\Toon Boom Harmony Essentials\full-2110-pref

Then open the document:
Harmony Essentials-pref.xml (Make a backup in case this doesn’t work for you.)

Add this line of code anywhere within the other lines of text:

This should turn off the inaccessible “Enable Playback Cache” feature in Harmony Essentials.

Now, when I play my animations in OpenGL mode, the antialiasing remains.

1 Like