Toon Boom Harmony 20 Not Letting Me Erase Anything

Hi everyone! I have been having this issue where I am drawing and editing a drawing perfectly fine then suddenly it stops letting me erase. I do not recall doing anything to cause this. When I try to erase anything, there will be a “stain” where I tried to erase something. It also won’t correctly select and move things around. My layer is not locked. On other drawings it works as it should, but for this one it won’t work. How can I fix this? Any insight would help! Thanks!


I tried that and it didn’t work, thank you for your help though!

Hi there!

Have you maybe accidentally drawn the shape on another layer other than the line layer? look to the top right of the camera/work view- see where there is a button with an eye on it and below there are 2 buttons with C and L on them? try selecting the C or L and try erasing then.

Let me know if it works!

Hey there again,

Your welcome, but i’m not satisfied yet lol

I assume you’ve check if you’re on the right layer before you try erasing, but i’m just mentioning that here just in case.
What is it that you are trying to erase? is it a pencil line, brush line, shape, or something else? if its a pencil/brush line, toonboom only lets you erase the object at its points, which u can check my using the contour select tool (i think there’s another one for brush lines, but i don’t remember-- just check all the select tool variations and test them on the brush lines).

Try selecting whatever you are trying to erase, see if that works.

If none of that works, let me know what it is you are trying to erase, maybe post a picture or video.

good luck!


Oh wait sorry, you mentioned that you cant properly select it. That sounds like a peg problem-- have you moved the peg of the layer around or changed its default pivot position?