Tool Submenus not always working

Hello,

I noticed that the tool sub-menus are not always opening up. For example, when I go to the line tool, a submenu should open up where I can select a rectangle tool. But this is not always working. Now, as I write this, a submenu is not opening up at all and I can only select the line tool. So, I have to quit and restart the program for the submenus to work again.

Is there a fix for this?

thanks…

…Actually, the restart didn’t work this time (it did in the past).

So, at this time I can’t even access any of the tool submenus.

What can I do?

When you mean the tool submenus, do you mean when you click and hold on one tool’s icon on the toolbar then it opens up and shows you the other tools beneath it? Or do you mean the tool properties view?

I have never heard this problem reported before. What graphics card are you using? Are you updated to the latest drivers? What’s your operating system?

~Lilly
Toon Boom Support



Yes, that is precisely the issue.

I just figured out that it’s only happening when I open the project on the Cintiq tabled (either with the pen of with the mouse).

My computer is up to date, but let me update the Cintiq drivers and see what happens.

thanks…

OK, so I just upgraded the driver to latest version and am still experiencing same problem (with mouse or pen).

My computer specs:

Mac OSX 10.5.8

3.06 GHz Intel Core 2 Duo
RAM: 4GB 1067 MHz DDR3

NVIDIA GeForce GT 130:

Chipset Model: NVIDIA GeForce GT 130
Type: Display
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 512 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x062e
Revision ID: 0x00a1
ROM Revision: 3370

Hope this is enough info.

What can be done to fix this problem?

thanks…

I just discussed this issue with the testers who were working with Cintiqs, and they have not experienced this particular behaviour before. Which Cintiq do you have?

Is it possible that when you’re clicking with the Cintiq, that you’re moving the tip around a little bit so that it doesn’t expand properly? Also, is it possible that you might be bumping against a mouse and the two are interfering with each other?

~Lilly
Toon Boom Support

Thanks for looking into this.

My Contiq is 12WX (with latest drivers).

The problem is identical if I use the pen or the mouse. I did try very carefully, many times, not to move the cursor and not to let the mouse/pen interfere. So, this leads me to believe that the 12WX Cintiq is somehow not fully compatible, somehow.

Any ideas?

If it does it with the mouse as well, then it should not be related to the Cintiq itself, but probably something else. I think what I’m going to have you do now is send an email directly to support@toonboom.com and tell them your two problems - you can link them the threads here if you like - and they can troubleshoot with you directly what’s going on.

Thank you for your patience.

~Lilly
Toon Boom Support

Thank you for taking the initiative to forward this.

Actually…

I just figured out what is actually happening with the submenues.

The submenues do open, as it turns out, but they do not open on the Cintiq screen itself. Basically, they pop up on the main screen, when I click on the Cintiq screen.

Sorry I didn’t even notice this before. I simply didn’t see it because I am obviously looking down ant the Cintiq, when I work on it.

So, at least this brings us closer to a diagnosis.

Any idea how this can be fixed? Perhaps in the preferences?

thanks…

I verified with the Cintiqs here that it is possible to get the tool to expand onto the screen if the toolbar is to close to the edge of the Cintiq. If you drag the toolbar in a little so that it’s away from the edge of the Cintiq, then you click on the tool, do you now see the expanded window on the Cintiq?

~Lilly
Toon Boom Support

Lilly,

I tried as you suggested, but I’m afraid the submenus are still expanding into the main monitor. I actually moved the edge of the workspace quite a bit far from the edge (about 2.5 cm) and it was still doing it. It finally stops doing ti when I move the edge of the workspace away from the edge of the screen about 3cm. But since I’m only working on a 12WX Cintiq I can’t really minimize the size of my workspace so much.

Any other ideas?

thanks…

I don’t know if this helps but you don’t actually have to move the whole workspace - you can just drag the toolbar itself over. If you put your cursor over the two lines at the top of the toolbar (if it’s vertical) or the left of the tooldbar (if it’s horizontal), then you can drag it over. So you can actually have your workspace maximised, but just move the toolbar itself over.

Does that work?

~Lilly
Toon Boom Support

Lilly,

I don’t quite understand what you mean. TO drag the toolbar where, exactly?

My toolbar is now at the side of the screen in vertical orientation, which is exactly optimized to have the bet size of workspace. I have a small 12" Cintiq and don’t really have much space to reposition the toolbars as I would lose some of the valuable workspace.

But perhaps I am not quite understanding what you mean.

If you’re running into this issue on your Cintiq, then it’s probably worth your while to try to drag your toolbar over to a horizontal configuration, to see whether this improves your workflow. Have you tried a horizontal configuration?

~Lilly
Toon Boom Support

Hi Lilly,

This is an issue that really needs attention in further releases of Animate.

I am used to having a vertical window orientation (my main monitor on top of my cintiq). If I have this orientation, this same offscreen problem happens with the upper tabs (file, edit, view, etc). So, I switched my monitors to a horizontal orientation and then the problem is on the tool bar.

The one problem with the solution you suggested about moving the tool bar into a horizonal orientation is that there isn’t much screen space as it is with all the other horizontal bars…especially on a 12" cintiq. So for now I think I will do that, but as soon as this issue is resolved I will be happy to move it back to the left.

Cheers,

Michael

Hi,

You can also adress this by making your Cintiq the left screen in the orders of screen. It does not need to be your primary monitor but the left edge need to be the end of your computer’s desktop. This issue has been reported to the RnD department but you should be able to avoid is using the solution above.

Best regards,

Ugo