"Timeline Warp" during Symbol edit (on PRO, too)

There is a very strange thing that happens to the timeline when I work with Symbols. I have already reported this before, but I found the same problem on Animate PRO PLE, so I figure it’s a good idea to underline it again.

I can’t explain this without an example, so here I go:

Let’s say I am on frame no. 2500 on the main timeline, and some Layers downwards.
I need to edit a Symbol, so I select it and enter Edit with cmd-E.
After having edited the Symbol I exit it by selecting the little ‘Top’ house icon.
Great. Now, I would expect to be taken back exactly to where I was, at Frame 2500, and on the same Level.

But no, instead, here is what happens: the playhead stays at frame 2500 (that is I can still see what I was working on), but the timeline has skipped back to the beginning and up to the top layers. Yes, frame 1 and top layer.
In two words, there is a discrepancy between where the playhead is and what I am seeing on the timeline.

So, of course, to continue working, I have to scroll back and find where the playhead was. Which, when you have a long stretch of frames and many levels can be quite a task.

This is probably the single worst thing I’ve found so far. It’s mind-boggling. If I use many Symbols and edit them often, it’s a genuine torture. This bug, or whatever it is, forces you to add the frustrating game of ‘Search for the spot you where’ every time you work on a Symbol. Very very frustrating, to say the least.
By the way, the same thing happens the other way 'round, from main timeline to Symbol timeline.
Basically, it looks as if the timeline is shared in such a way that it doesn’t change view when switching between Main and Symbol.

As said, I have already reported this via Support and it appears it actually is a glitch and that it will be solved, but I am reporting again here because the same problem appears on Animate PRO, which I am currently trying out.
I’m loving Animate PRO, but the idea that after upgrade I’d still be experiencing this timeline pickle is a definite turn-off.
It’s great to be able to do more and more, but workflow should be as un-hampered by unnecessary repetitious actions as possible.

Is there any way of knowing how and when this will be solved? I mean, especially in view of going Animate PRO.


thank you for lending an ear to my grievances, and for the great work…

Josh

Hi Lily and thank you for the answeryes, in fact I wasn’t sure where to post it.I know well that a lot of so-called defects are subjective, but this one really gets in the way, impairing one’s workflow, which we know, is important. If it isn’t a bug, it sure makes an effort to look like one :slight_smile: I was also disappointed to find it on PRO.To this day I have found none (or very few) things I would like added to Animate. Animate is tightly packed with features, no question about that. That’s why we love it :)On the other hand, I have spotted tortuousities and user unfriendlinessses (some already posted in the forum) which put the working experience in a lower league than its features.I could say the place Animate takes you is wonderful, but the trip to get there could be, in some respects, smoother.Thanks again very much,Josh

Thank you very much for your input!

It’s not a glitch or a bug so much as a functionality that was never implemented.

I believe that there’s already a feature request for this one in the feature request section, but you can go ahead and post this in that forum as well and then the plan is that we will be evaluating all the posts in there for future versions of the software.

~Lilly