the grey death of animate menu items

I’m wondering if this happens to anyone else.

I’ve been using Command+C from the camera view to copy drawing objects (to get the pivot) and then going to another drawing, right clicking and using Paste Special Again in the popup to copy the pivot location between drawings.

No problem until just now. I stepped away and my Mac went into sleep mode. When I came back, the Paste Special option was not working.

I added an empty drawing to create a new peg, then created the cell and extended the exposure. Select the drawing, right click in the camera. Now on the popup, Paste Special and Paste Special Again are greyed out.

This was driving me crazy since it made no sense. The right layer is selected, the right cell, the pencil icon is on the layer, it’s not locked.

I tried deleting the layer. Made no difference.

Tried it on a layer that this had been working on. Made no difference.

Here’s the copy:

Here’s the paste:

See the problem? If you did, you’re wiser than me. I had to go back to the tutorial and follow through the steps again before the solution occurred to me - I had somehow turned on Pivot instead of Transform.

Sometimes I hate the way that context sensitive menus make me feel like a fool.

Hi Mdhender,

The confusion begins when is applied the Cmnd+C or Ctrl+C = copy
The copy functions are focused to “copy drawing object” if you has the focus in camera view, and if the selected tool is pivot tool, then copy the pivot in other/s cells as drawing object and you can paste it directly with “paste drawing object” (Cmnd+V or Ctrl+V) focusing the camera view.
You don´t need any special function for copy here.

Now, if you make focus in a timeline cell and do right click, being pivot tool selected, in the menú appears “Copy cells from timeline” and the shortcut is the same (Cmnd+C or Ctrl+C), but here you are copying the “cell properties” not only the drawing object, and you can go to paste these properties in other/s cells with paste special, because you are selecting copy only the pivot position, and need choose: Do nothing>Update Drawing Pivot. If you here simply paste (Cmnd+V or Ctrl+V) you are copying all the cell properties that includes the exposure.
It´s clear now, why paste special apperars grayed when you make focus in camera view and not when you copy a cell from timeline? Hope that helps you.

Best Regards

Just as a little bonus here, in Animate and Animate Pro 2 you can copy the pivot directly using the pivot tool.

Just select the pivot tool, select the drawing you want to copy the pivot from, and do a Ctr+C. Then select the destination drawing and (still with the pivot tool) do a Ctrl+V. Voila!