Templates causing pieces to move in z axis oddly

Hi!
New user here, sorry about the hassle ahead of time.

I’ve been building a cut-out puppet rig following along with the video tutorial and I’ve run into an issue.

When creating the template I’m getting an odd scenario where when switching the template between views, things start to get wacky.

When switching views from 3 quarter to profile, for example… the templates work great. As I switch back from the 3 quarter to the side however, things begin to go haywire.

Parts of the face completely switch up and it seems as if the z axis positioning of the pieces of the face change (even though they’re identical in timeline between views on the master scene).

The oddest bit as well is that when I reset the cells completely and start over from scratch (using SHIFT+R) and manually place the z position of all the face elements in the proper order, things seem alright until the templates are made again and everything goes wacky once more.

Another interesting thing is that if I delete ALL the frames except for the original side or 3 quarter profile images (ie: 1 single frame on the entire timeline), things shift about on some of the cells as well (even though there are no keyframes).

Sorry again for such a long post and I know its most likely user error on my end…


I’ve screen captured the phenomenon happening and the link is as follows:
http://vimeo.com/34537058

All of your points were the issues!

Thanks Lilly!

From looking at the video it looks to me like it’s not necessarily an issue of keyframes, but of frames themselves. When you drop in a template, what it does by default is it extends the exposure of the previous elements up until that frame. I think that in your profile view, you probably had no drawing for one of the eyes. So then when you dropped the other view in, it extended the exposure from the first view over the profile view.

You can either turn off Extend Exposure on your drag options (hold down Ctrl when you drag in your template) or you can put a blank drawing in there. I.e. Create Empty Drawing, and then don’t put anything in it. I prefer the method of having an empty drawing, just because then you know you’re not going to run into trouble.

Regarding the second issue that you show, when you are editing the Z position on your elements, you are creating keyframes for those different views. So if you remove the keyframe, it’s going to reset the Z values.

Then I can see that when you are creating the two separate templates, you have a keyframe on one of the master peg layers on the one pose, and you don’t have a corresonding keyframe on the second pose - so naturally, when you delete the first keyframe, things are going to move on the second pose. You need to make sure that you collapse everything and create a keyframe before you delete the pose.

~Lilly

You’re welcome! I know it takes time sometimes to get running, so I’m glad I could be of help!

~Lilly