TBS won't export all frames

When I export my animation into a flash file it doesn’t play entirely.

When I play the animation after it is exported it stops at frame 190. (out of 290 frames) I’ve tried making adjustments so the file size is smaller, but that doesn’t seem to change anything. It does the same thing when exported to a quicktime movie. All of the export options are unchecked (protect from import, include preloader…). “Launch Player After Export” is also unchecked. Export type is set for full movie and all frames.

I don’t get any errors while exporting it which is strange: “Flash Export Complete, your export was successful. You can now open the SWF file in a Flash player.” I do however notice that the progress bar stops at around 70% when it is exporting.

Any help greatly appreciated. Thanks.

TBS 4.5
MacOSX Leopard 10.5.5
2.5 GHz
4GB ram

Does your animation contain heavy texture fills? One of my own had them and caused it not to export completely. I replaced them and it exported perfectly again.

If that doesn’t fix it, you may consider creating a new scene and copying/pasting every element from the old scene into it. This can be a hassle if you have a lot of pegs, but again, it worked for me too.

Hope this helps. ;D


How much hard drive space you have left on your machine?

I’m surprised you do not get any kind of error if the render was incomplete. Is this something specific from this project or do you get it on all project you make.

Best regards,


webkroozer–No, my animation doesn’t contain any heavy texture fills. But I’ll try creating a new scene and copying and pasting like you said. I’ll see if that works. thanks.

Ugo–I have 17GB of space left on my laptop. This is actually my first project with TBS–so I just now made another simple quick animation with the same amount of frames (290) and it exported the whole thing.

I suggest that you check your export settings to be sure that you have them set for Export Type: full movie and Export Range: all. This is one of those things where you may have accidentally switched the settings and not realized it. Just a place to check. -JK

thanks webkroozer. I was able to copy and paste everything into a new scene, and it is now exporting correctly. FINALLY. I still don’t get why that happened but at least it works now. thank you!