Swf file generated in Harmony is acting strange in After Effects


Does anyone use swf files generated from Toon Boom in AE?

Here is a problem i’m having:

It seems that AE doesn’t read well some of the frames in my swf. It suddenly freezes the swf movie after a certain number of frames, in the end of the animation although it preserves the original duration of the swf clip.

The animation is simple, hand drawn, no interpolations, no symbols and only thing i imagine that could be problematic is the fact that i used the “paste reverse” option at the end of the animation to copy frames in reverse and close the looped cycle.

When I export it the swf file is playing properly in flash player/debugger but the moment i import it in AE, even flash player starts playing it with the same bug, meaning it freezes at the same moment but the clips duration is unchanged.

I’m using Toon Boom Harmony and AE cs6.

Sorry if my description is too long or confusing. My english is not so good.

Thanks in advance for any advice.

in all honesty, idk if harmony is causing your issue with the SWF. i’ve had SWF exported from FLASH act strangely in AE. despite playing back correctly in flash, in the swf heads and limbs would just pop off for no reason, frames would freeze up and not play back properly, etc. sometimes, a swf that worked yesterday didn’t work today, and i just stopped using them because they became so unpredictable.

In my current project I depend on flexibility of using swf files because they can be scaled without resolution issues.

My animation is really simple - one layer, just drawings, no frame interpolations, symbols etc.

Thanks for the reply Frank!

For anyone who encounters this problem, there is a solution on creative cow forum:

Brendon Eldridge Re: swf problem in After Effects
by Brendon Eldridge on Nov 12, 2012 at 8:55:40 am

I think I’ve found a solution to this rather annoying issue (in CS6 at least, haven’t tried with 5.5 or lower): You just need to disable “Write XMP IDs to Files on Import” in Media & Disk Cache preferences. I’m not sure how important this setting is, but it seems to stop swfs from being wiped when you reload/update them.