Surface Pro Pen Pressure always dropping out in SBPro (“Use Qt Wintab Tablet Support” already toggled)


When I use SBPro on my Surface Pro 7 - the pen pressure sensitivty always drops out. It works for a bit, and then randomly stops (leaving clunky lines).

I’ve researched online fixes - and tried the “Use Qt Wintab Tablet Support” preference option, as well as making sure my drivers are up to date.

To be clear, the pen’s pressure works perfectly fine in other apps - including Photoshop. I can literally jump to and from SBPro and PS and have the pen work perfectly in PS with sensitive line strokes, and then jump back to SBPro and have it not work.

It’s inherently an SBPro problem with the surface pro’s stylus. For example, when I use my Desktop PC with a wacom cintiq - there is never an issue in SBPro with the wacom stylus there. Same SBPro software. Same OS. It’s only ever on the surface pro. And only ever in the SBPro app. Only that combination.

What can we do to correct this as it get’s frustrating to the point where you can’t draw. A short workaround is closing and reloading SBPro, where it works again. Breifly. But when working on large files this can take a lot of time - closing, opening, closing, opening.

There has to be a troubleshoot fix for this? Any ideas?

What version(build) of SBP are you using? You can find this out under Help and About in the main menu. When you say ‘Wintab Tablet Support’ toggled is it checked or unchecked?

This is on SBPro 6, v14.20.2 (which I have installed on both my surface pro 7, and my desktop to correlate to the above info - the desktop install is sbpro 6, v14.20.3).

“Use Qt Wintab Tablet Support” is toggled off (under Global UI > Tablet Support in sbpro 6).
It has also been tested with it toggled on.
I mentioned this - as it was suggested as a ‘resolved’ fix under other postings regarding this issue - but it is not solving this issue here. So I just wanted to clarify everything i’ve tried to fix the issue thus far (which also inlcludes updating drivers for the surface pro pen etc etc).

Also, just to clarify again - this issue is only prevalent on my Surface Pro - the SBPRo installed on my desktop, where I draw using a cintiq and wacom stylus - has no similar issue.
Also, every other drawing app installed on the same Surface Pro (eg Photoshop), has no issues with pressure sensitivity when using the surface pro’s stylus. It is exclusive only to SBPRo on the Surface Pro.