stupid novice question

I’m brand new to Toon Boom Studio, but familiar with various bitmap-based ink & paint software. I very much like the overall look and feel of TBS, but one
quick question. I’m using an unusual aspect ratio for an experimental project. I did a quick test drawing and exported a frame as a jpeg still. The output still is not framed the same as the Camera View frame shows (The Camera View is framed tighter by a good amount.) I’m sure this is a novice blunder, but I can’t find anything in the help file to guide me. Any guidance appreciated.

Did you make sure that your animation settings match your custom resolution? You can set this when you first create your project, or you can also double-check it at any time by going File > Animation Properties.

Thanks for the response. To make sure the problem wasn’t my custom resolution, I started a new project and used a preset rez, namely 1280 x 720, and got the same result, a camera view that is tighter on the drawing than the output jpeg image. I should explain further that my TBS is not the latest. It is version 3.5, listed in the “about” screen as build 3.5.058. I’m running Windows XP Pro SP2 on an Intel Core2 CPU. I can post screen shots if anyone thinks it would help. Thanks again.

Hi,
I did a test for this issue on TBS 3.5 and TBS 5.0 and both vector and bitmap still image exports have responded accurately to the camera frame size allocated in my test projects, in 1280 x 720 to the maximum size of 2000 x 2000 px x 72 dpi. and the image size was the same that each project settings. Always image offset: 0N-0E-0F. Scale factor: 1
I imported a jpg in 1280 x 720 px x 72 dpi in project camera settings: 1280 x 720, and a jpg 2000 x 2000 px x 72 dpi in project camera settings: 2000 x 2000 px.
I exported to jpg in 1280 x 720 px x 72 dpi (project camera settings: 1280 x 720) and 2000 x 2000 px x 72 dpi (project camera settings: 2000 x 2000 px) in TBS 3.5, the result was exact in both cases and was tested in photoshop.
The same procedure was made in TBS 5.0, but the export was a png format.
If the camera FOV properties are the standard 30 deg and the camera offset in 0N-0E-12F and located the image properties in 0N-0E-0F, scale factor 1, the result would be similar to the test.
Make your checkout using these parameters and see what happens. Good luck. Regards. Yoryo.

yoryo;
Thanks for your reply. I checked the parameters you suggested and verified they are set as you specified, and my output jpg is still not the same as the camera frame indicates. I will continue to work on this; I’m still certain I’ve
set something wrong somewhere. I will repost if I figure out what my screwup is. Thanks again. monteG

Yoryo;
One thing: I’m not importing an image, I’m drawing with brush in the drawing window. Would that have any effect on output? Thanks, monteG.

Hi,
No, you would get the same results with vectors. The animation properties define the size in pixels of the frame that you are working on. You only can modify the visual amplitude of the frame exported when you change the art position F/B, transform size art, moving the camera position F/B using a parent peg, with the motion tool, or setting the camera as dynamic. ( dynamic FOV ).
Create a new project 1280 x 720 px. In the default drawing element, make a filled color rectangle with external stroke in other color in coincidence with the camera frame showed in camera view, (dark brown) at this moment all positions are in default, your art are 0 E - 0 N - 0 F, scale 1 and the camera 0 E - 0 N - 12F and 30 deg. Make a export frame as jpg. This jpg contains a rectangle with a visible stroke and this size is 1280 x 720 x 72 dpi, the same as camera view. This is the normal result that you would obtain. Works this way? Regards. Yoryo

Yoryo;
Thanks again for your input. I did everything you suggested, i.e. new project @ 1280X720 p, made a red rectangle to the edges of the camera view frame, filled it with yellow, and exported a jpg still image. My result was the same, a smaller rectangle in the image. Specifically, the rectangle measures 902 X 507 pixels on a white background that is, of course, 1280 X 720 pixels.
I verified camera properties as 0N 0E 12F and drawing properties as 0N 0E 0F. The mystery abides!

MonteG:
Considering that we both made the same test, but results have not been consistent, and exclude the presence of masks or no default locations in the position of the layer of art, camera position and the creation or use of another camera in the list, suggests that an error could be affecting the result.
When you render in Quick Preview, Preview Scene (show size report)
or Export Movie, your image is cropped in white as the jpg exported?
Have you tried allocating more memory and setting other options for rendering (as OpenGL active) in the display preferences? Have you a good video card in your hardware? Finally, you could try reinstalling the software. If you can find a solution, make know to users in this post. Thanks. Best Regards. Yoryo

Yoryo;
Success! Your comments about the display/rendering led me to experiment with the Preferences/Display settings, and checking the “Disable Overlay” box eliminated the problem. I have no idea what an"overlay" is, but the problem went away; camera view now accurately displays the final jpg output. Thanks for your help. I’ll research this further when I have time, but for now I can continue with my ToonBoom experiment.

Hey I just noticed I am having a similiar problem. I have Studio 5, and when I did a test shot and exported it, it gets cut off. I have my screen set to 1280 x 720. Any way to get the full shot?


Hi JamesN,
You can check the final solution as you can read in the quote. Regards. Yoryo

Hmm…thats odd. I went into preferences and display but theres no overlay box.

wait a tic. After fiddling with it for awhile I unchecked some box and adjuted the size to 1280 x 900 and its an almost perfect fit to the camera view from what I see. More testing is needed.

Ok, is true, Disable Overlay is found in TBS 3.5 display preferences. (That is the TBS version used by monteG) In TBS 5.0, in the same location, now is found: Improve Pencil Rendering Performance.
If all works well now, the camera frame will have exactly the same size as the image rendered. Yoryo.

Thanks a bunch! It totally works now. First problem with Studio averted! lol. Thanks again. :smiley:

I’m using an unique vista ratio for an experimental attribute. I did a fast judge draftsmanship and exported a framing as a jpeg plant. The production works is not framed the comparable as the Camera View framing shows (The Camera Orientation is framed tighter by a satisfactory total.) I’m reliable this is a tyro bloomer, but I can’t feat anything in the provide enter to run me. Any control gratifying.
------------
cruz
laptop repairs London