Strange misalignment with brush / pen cursor

I currently own a Cintiq 13HD, and my pen cursor’s acting a little strange with the brush tool in Harmony. Despite of calibrating my cintiq, the brush cursor (in a shape of a dot) is diagonally far off from the pen’s cursor. Even angling my pen doesn’t change it at all.

I check it with Animate Pro, brush cursor’s alignment to the pen is fine.

Are you attempting to draw on a layer which is being deformed? The only time I experience this issue is when a deformation is enabled… In this case just click on the deformation “Setup Mode” button (white hammer icon) and make adjustments to the drawing before switching it back on.

I don’t think I can find that white hammer icon anywhere you were talking about. Where is it exactly?

Also, I’m not sure if the layer is being deformed. It is just a fresh new file opened up.

i ran into a similar problem myself a fe days ago when i upgraded my system to an SSD and re-installed Harmony. when i loaded up my handy wacom preferences file, it caused harmony to batty. i couldnt even re-size workspace windows. everything else worked fine except for harmony.

i re-installed my wacom drivers and did NOT load up my preference file. it was fine after that.

I am having the same problem. I own a Cintiq 13HD as well. It works fine drawing with a mouse, only when using the cintiq does it do that. I was wondering if you ever found the solution to this?

Do you happen to have a multiple-monitor setup by any chance?

I have this same problem as well – the offset seems to grow larger the more displays you attach. The temporary fix, it seems, is to disable any extended desktop features altogether.

Been meaning to submit this as a bug for a while. This seems to only happen in Harmony. No other Wacom-aware applications I own can reproduce the issue. My setup is Windows 7-based, so I cannot confirm if this affects other operating systems.

Hopefully someone in support is watching… :wink:

Write support and explain your problem to them. I have a Cintiq 12WX and when I recently updated my version of Harmony the cursor was off. They sent me an updated version of Harmony and it fixed it right away. That may or may not be the solution but I’m sure they can help.

Something like this happened to me. If you’ve already re-installed or updated your wacom drivers, I’d recommend checking your graphics card to see if there are any drivers that need updating.


Here’s what I usually do to fix this issue :

  1. I close every application on the computer.
  2. I uninstall the Wacom driver and delete the Wacom Preferences.
  3. I clean the Registry to get ride of anything related to Wacom.
  4. I reboot.
  5. I check if there is a more recent driver.
  6. I install the Wacom driver and perform normal calibration as if it was the first time…

9 time out of 10, the offset is gone and pen sensitivity is good.

The registry key to delete is usually located here :

I hope this helps.

Best regards,
Francois Grossin
Technical Support Specialist
Toon Boom Animation


I followed your instructions exactly and it did not fix this issue. I am not able to really be productive with this defect.

Update: I just spent 1.5 hours with Wayne in Harmony support. He deleted a vast array of files that seemed to be much more than I could ever find, even by your method described above. Maybe I didn’t understand exactly. And my previous Mac computers did not seem to have so many hard to find files… It was long, long process. My cursor seems to be acting correctly now. Wayne appears to have done a good job.

Two posts above yours is the solution that usually works.

You basically need to remove ALL tablet drivers and ALL tablet preference files.
Re-install the latest one. If it didn’t work you likely missed one. Contact support if you’re stuck.

Hi, I just purchased a Cintiq 13HD and the courser is off by an inch, I’ve uninstalled, reinstalled the Wacom drivers, I reset the Wacom preferences, I restore to default preferences in Toon Boom, and my courser is still off. Is there a fix? I’m using the most recent Cintiq driver on Wacom 's driver’s website.

I kept having this problem even after trying to uninstall / install drivers.

The problem was my scaling, the screens were set to 125% (Win 10),
and when I put my main screen to 100% again it misaligned the cursor.

Now all are set to the same and the misalignment is gone.

maybe is a little late but


-right click at the harmony application icon
-compatibility tab
-in settings section check: disable display scaling on high DPI settings

this is it. fixed.

I have a cintiq 13HD touch and windows 10, Harmony premium, nvidia video card.
you don’t have to remove any drivers at all.

hope that helps

Our problem is cursor offset when using a dual monitor setup in extended desktop mode.

We are using a Ugee UG-2150 tablet (that Toon Boom does not support).

Just got offline from a remote access session. Toon Boom tech support sent us “Team Viewer” which we installed and which allowed Toon Boom to control our PC.

It was rather frustrating because TB kept asking us questions we had already answered (eg, “Are you using Windows 10?” when we had already provided all the specs of our software and hardware).

And so it went for about a half-hour…TB rounded up the usual suspects (eg, do the resolutions match?, is the scaling at 100%%, is the scaling disabled?) and nothing changed.

And of course nothing is going to change because TB did nothing we hadn’t already tried ourselves, and had already explained to TB.


Anyway, bottom line, until either TB or Ugee work things out, separately or together, the two products (Harmony Advanced and Ugee UG-2150) will not play nice together in a dual-monitor setup in extended mode. (When both monitors are clones, the cursor tracking is accurate; when one monitor is an extended desktop of the other, the cursor is offset).

I will write – again – to Ugee and see if they can do any better at resolving this mismatch of hardware and software.

Could you be more specific? I’m having the same problem with a 13HD and Windows 10. Where exactly do I find this compatibility tab? I only see “troubleshoot compatibility” when right clicking the icon.

I use Macs and the user may not see your message in time so try that “troubleshoot compatibility” and look to see if there is a settings section to check: disable display scaling on high DPI settings.

Have you checked if your Cintiq screen is scaled to 100%? That could be one cause of the problem and it’s easy to fix.

If you have harmony on your desktop or taskbar or have the application open, you can right click it, then scroll to harmony and right click again. From there click “properties”. You should then see the “compatibility” tab. Then just check “disable display scaling on high DPI settings” and hit “OK”. Restart the application if you have it opened.

This worked for me on windows 10 without doing the uninstall and reinstall process.

Thanks so much mikeymkk, that totally solved the issue for me! Just to clarify for others, cause it took me a second to figure out what to do from the above comment… (this is on windows,)

Right click on the Stage Icon
Scroll down to the bottom and click properties
Go to the "compatibility: tab
at the bottom, click, Disable display setting on high DPI settings.

Sorry to just parrot your post, but it totally worked. I was worried for a bit there…