Storyboard Pro constantly crashing out! Super frustrated!

Hi Everyone,
I am new to Storyboard Pro and I have some real struggles with it. I downloaded the trial version on my Macbook Pro. I am not sure if its due to the trial version or it is not compatible with my Macbook Pro, Storyboard Pro keeps crashing out. Things are driving me crazy include:

  1. Every time after I use layer transformation tool for a few times, it will not work any more. To enable layer transformation, I have to close out Storyboard Pro and reopen it again. Same thing happens to camera mode.
  2. To move camera or layer, it is super super super slow. I have to constantly try clicking on camera or layer for a few times, then it can be moved. And even when I move the layer or camera, it can only be moved possibly only one bit at a time. If I want to move the camera from left to right, I have to drag it for a lot of times!!!
  3. Edit sound track - I want to change the volume of different sound tracks. After I click “show volume”, I can see the line in the track. But when I click the line, nothing happens. I watched the posted video here, is it suppose to show a white square and then I can drag the line to change the volume?

Please help! i don’t know if there are some settings I need to modify, or I am just using the Storyboard Pro wrong. I am very frustrated.

Thank you!!!

If your Macbook pro has a weak graphic card try closing other programs
and web pages. Try creating a project that uses a lower resolution.

For usage, it helps to view the tutorials that are accessible from
the “Learn” link above.

I watched all the videos in the Learn. I tried everything in the tutorial. They just don’t work properly on my laptop. How weak is considered as weak for graphic card? I just bought the latest version of Macbook Pro on the market. Just simply wondering if there is any upgrade I can do.

Thanks.

Without knowing the graphic card model of your Macbook Pro I can’t say.
Since you can’t replace hardware on these systems you need to make certain
it had a decent graphic card before you purchase.

Hi, I went to the website, and in the Graphic section, it says:

Radeon Pro 555 with 2GB of GDDR5 memory and automatic graphics switching Intel HD Graphics 630
Configurable to Radeon Pro 560 with 4GB of GDDR5 memory

I am not sure if it is due to the graphics. If not, any troubleshooting process could you recommend please?

Thanks.

Have you tried turning OFF automatic switching between graphics, and running only the Radeon card? Automatic switching may cause all sorts of issues in software that uses OpenGL.