Storyboard Pro 7 Is Now Out!

Hello all,

We are proud to announce that Storyboard Pro 7 has released today!

New Features to Storyboard 7 include:

Industry-leading, improved stylus responsiveness

  • New stabilizer for lines that are smoother than ever
  • Customizable stylus pressure responsiveness
  • Tilt and angle responsiveness

Stay on-point with new rulers and guides

  • Drawing ruler
  • 4 point vertical pan and continuous perspectives
  • Fisheye (5 point perspective)
  • Isometric perspective guide
  • Camera and stage alignment guides

Collaboration is the name of the game

  • Link projects to facilitate merge operation
  • Improved merge and replace (editor-artist pipeline)

Advanced control, sound editing

  • Set gain on audio clips
  • Synch audio and video tracks with panels
  • Drop audio files from an external file browser to the library or timeline

Advanced editing & efficiency

  • Import/export preferences & shortcuts
  • Export movie files (h264 compression without Quicktime)
  • Insert empty space between panels and scenes
  • Copy a layer from a panel to a video track
  • Multiple camera views

In addition to all of the above, other new features and a large number of bugfixes are also included!

Want to learn more? Visit the Storyboard Pro 7 section of our website here:

I had this problem too, and it only happened after I altered my Keyboard Shortcuts to my liking.

I found that going to Keyboard Shortcuts → View → Free Pan and Zoom and resetting it to default resolved the problem for me. It’s a weird glitch, but it worked for me and now I can actually get to work.

Hope this helps.

I am having brush issues with the new StoryboardPro7 The “brush” on reads like the “hand” tool. I am using a Cintiq 22HD on Windows 10.

Warning for everybody thinking of switching to SBP7:

A glitch on 7 has me stuck in the zoom tool at all times. I select brush and it shows the brush settings in the side but it’s stuck on zoom. Restarted SBP7. Restarted Computer multiple times. Before this happened, other buggy stuff was happening too.

I’ve lost a lot of work time trying to fix this. Be aware that there are big issues with 7 as of this comment time.

Well, their licensing seems to be broken anyway at least for me. My guess is tech support is overwhelmed at the moment.

Hello QDrawk,

Can you give me more information about what kind of PC setup you have? We’d like to investigate this bug internally to see what triggers it so that we can issue a fix, so any and all details you can provide on this bug will go a long way to helping us solve it!

This does not seem like a widespread issue (from what we can see) at this point in time, so if anyone else also runs into this issue please let us know your PC/Mac specs and what you were doing at the time of the bug being triggered for our awesome QA team to follow up on.

Thank you!

Hello rimcrazyph,

Were you able to get your license solved? Our support team does have quite a bit of work at the moment but I want to make sure that your case is not forgotten about!

Hello BrianMarcW87,

If I am understanding correctly, the brush and the hand tools are getting confused on your setup? If so, I will be forwarding this bug report to QA!

I also have a new leovegas reviews of online slots on the project, for those interested of course, but in general play it wisely.