Storyboard Pro 4. Paint brush, pencil and eraser lag about two seconds.

I have recently replaced my old Storyboard Pro 1.5 with Storyboard Pro 4.2. and I have encountered three problems:

  1. The brush, pencil and eraser tools lag about two seconds when I try to draw.
  2. Drawings appear (after a couple of seconds) in the thumbnail and panel view, but NOT in the drawing space in Stage View. I must set Opacity down from 100% to 99% in Layers for drawings to appear.
  3. The drawing panel turns black when I enable Realistic Preview.
    In the Advanced settings I have tried to enable Full Scene Antialiasing. I have also tried to set the Delay Before Vectorized Strokes to different values. None of these adjustments make any difference.
    I am using Mac Pro (early 2009) OS X Yosemite, Memory16 GB 1066 MHz DDR3 ECC, Graphics ATI Radeon HD 4870 512 MB and a Cintiq 20WSX.
    Attaching screenshots to show settings and problem with opacity.
    Has anyone experienced these problems?
    Thank you.

If I had to guess, I’d say that it’s more specifically a lack of graphic card RAM problem. The card on the machine having the problem simply does not have very much. It will be made worse if you’re using two monitors since the available resources are split between the two displays.

Try to limit the use of bitmaps and texture as they tend to fill the graphic card RAM. Also try splitting the board into acts while working and recombine them again at the end for the output.

i had same lag problems using my old Mac Pro (2008)
I just got a new iMac and problems have all gone away ( fingers crossed ) - maybe time to upgrade ?
i found upgrading my old machine to yosemite was an upgrade too far.
Hope that helps .

Update: Just downloaded and launched Storyboard Pro 4.2, i.e. same version as referred to above, on my Macbook Pro and I am not having any problems with delay or opacity. I guess it must be a graphics card issue (?)