Starfield Fly through Problem

Hello Friends,

I am pretty new to Harmony Premium. Currently I am working on an Animation Teaser for my University. I want to make a Starfield Fly Through like seen here: https://www.youtube.com/watch?v=KaCsZQRPZqU

So I tried using the Particle Systems 2d and 3d but it did not work out for me. I played with the Velocity and the Spawn and Movement direction like changing the Gravity direction only to + Z axis. I also tried messin with the Confetti particles and it made everything worse.

Can someone tell me how to do this? Sry For my bad Denglish

You can start with the Rain example. Change the drawing/sprite or ‘render as dot’ if that works for you (Rendering tab of the Sprite-Emitter module), and change the direction of the particles towards the camera). There’s a similar example discussed in this thread: https://forums.toonboom.com/harmony/support-and-troubleshooting/reverse-speed-lines

There’s also this thread: https://forums.toonboom.com/harmony/general-discussion/sand-storm-particle
which links to this useful tutorial: https://www.youtube.com/watch?v=pfk7t5Y_gTs

With the Rain example, a good start will be to go to the Velocity module and change the Z to 1 (X and Y = 0 ). That would make the particles move towards the camera. Then you need to rotate the Planar-Region connected to the Sprite-Emitter so that it faces the camera (to see the region, click on its module and then Show Control via the icon on the Camera View or by using the shortcut Shift+F11). Yo can do that manually or changing the Rotation parameters of the peg connecting the Planar Region (X, Y, Z = 0 ). Then you need to centre the region and resize it as you please. You can just drag and resize the area with the transform tool, but you can also change its size on the Planar Region properties.


Luis Canau

Thanks Luis,

Ok now i got it to work properly. But im still struggeling with the velocity of those particles. I want to make them fly slower in certain Points in the Timeline when for example a Planet is flying by and it slows down a little to see the details on that Planet. Then the Planet flys towards the Camera and the Stars become faster again.
Any Ideas how I achive this? I tried changing the Speed through the Velocity Peg but it did not change the Speed at all.

Thanks for the Help

Amrit Raj

Check the Velocity Type on the Velocity node properties. You can try Interpolated or Constant Speed. With the first option you can have a range of min and max speed, with the second you’ll only have maximum. You can keyframe those parameters so that the particles speed up or decrease velocity.


Luis Canau

Hey Thanks,

It was indeed the Speed: Minimum and Maximum parameters. Now it works really good. thanks mate! If you want I can send you a test render of the Movie Clip. :smiley:

Im sure i will ask more questions in the near Futur :stuck_out_tongue:

Have a nice Day!