Stange gaps/overlaps with textured pencil

Does anyone have a tip or trick for getting rid of the unwanted white gaps/overlaps that textured pencil tools create. I’ve attached a sample image that illustrates how the pencil stroke looks straight and then how it looks if you draw a sharp corner or overlap. I’m using a default texture that came with Harmony called “rough”.

Uploaded with

The pencil tool textures seem really powerful because they’re so much more editable than the brush tool, but if every line overlap/intersection is going to have all these gaps it’s pretty worthless.

I may be missing something obvious, but is there a workaround here?

Thanks for any suggestions you may have,

Well after a bit of trial and error, I solved the problem by DISABLING the checkbox in preferences>openGL>support transparency in Pencil Lines.

Very counter-intuitive. But after un-checking this in preferences (and then re-starting Stage) the pencil tool performs beautifully. No remaining white bits in the pencil stroke.

Hope this helps somebody with a similar issue.


Could a small blur help?

Does that also solve this issue when it renders? I don’t think it does, but let me know.

We have received this feedback before, and will look at the possibilities for improving this, but it is a very difficult one to address.