Sound out of sync after export


Anyone have this issue?

Sounds are not playing at their set start frames after exporting to any movie format.

The sounds are in the correct location in the timeline but always play right at the start of the movie after export.

I am using Animate on Windows 7.

I am unable to reproduce your problem on my end here. I thought that I had seen the problem, but then I closed and reopened animate, and on a different scene went through the same steps (importing a sound, moving it over to the right) with exactly the same sound file as the first time when I saw the problem, and now I’m unable to reproduce it. I’ve tried with several different files and using many different types of audio.

Can you identify if there is a specific type of audio that you’re experiencing this problem with? Are you using mp3, aiff, or wav files? Can you reproduce the problem with all three types of file?

Do you notice that the sound is out of sync only at the beginning of the file, or are there other parts where you notice it’s out of sync? To test this, keep your sound file at the beginning of the scene - now both the scene file and the output file should begin at the beginning. Do you notice them getting out of sync towards the end?

Is there any other useful information that you think might contribute to this? You said that it happens when exporting to any movie format - what formats/codecs have you tried?

I have tried it with mp3 and wav and export to mov and flv. I will try what you suggest and get back to you.

Below are the steps I have been following:

1. import sound file
2. Move start frame and end frame in the sound editor from 1 and 40 to 300 and 340.
3. export movie.

The sound plays at around 2 sec in. Should play at about 12 sec in (24fps).

@lhayes
what is the length of your animation? more than 300 frames?
rob

I think my last key frame is around 330. I do not have access to my file right now. I will double check.

my thought was the sound layer would be outside of the film scope.
anyway, you can select the frames of the sound layer in the timeline and move them physically to the left, too. (while moving the cells of the soundtrack will become orange, indicating the translation)

the trouble seems to lie in the sondtrack position in the timeline (or xsheet, depends on what you use).
rob

No matter where I positon it, the rendered file has the audio start basically in frame 1. The track is well within the scene scope. Looks great in the timeline and even plays right in scrub mode.

I even started a test file with a simple object and sound. No go. I might unistall and reinstall Animate.

Recreated the simple scene in TBS 5.0 with the same sound file and it comes out correctly.

I talked with R&D about this issue, and it seems that this is a known issue that has been investigated and will be fixed in the next release.

Lilly
Toon Boom Support

Is there a work around? Approximate date of a new release?

No word yet on a release date. There is no workaround - for your situation why don’t you email techsupport@toonboom.com and they can give you more specific information.

I will do so. Thanks to everyone for your time and input.


Has this issue been resolved with the new version?

This issue has been resolved in Animate 2.

~Lilly
Toon Boom Support

hi everybody,
I have the same problem with the sound! everything works out perfect when i´m working on my animation in animate pro 2…but when i export it, everything is confused…the longer the animation goes, the more the sound runs away (its faster than the pictures)
I think it has something to do with the export settings…it would be sooo great to have somebody here who could help me!
sorry for my bad english I hope you got the problem at all?
Thanks so much
xx

hi everybody,
I have the same problem with the sound! everything works out perfect when i´m working on my animation in animate pro 2…but when i export it, everything is confused…the longer the animation goes, the more the sound runs away (its faster than the pictures)
I think it has something to do with the export settings…it would be sooo great to have somebody here who could help me!
sorry for my bad english I hope you got the problem at all?
Thanks so much
xx