Sound import problem

Hi,

I’ve been searching on the internet a solution for this problem but couldn’t find one.

I’m trying to import sound to my scene and I can do that without any problem, no error messages. The thing is, any sound that I import just appears as a flat waveform on the timeline and, because of that, I can’t hear a thing. I’ve tried exporting the sound from my sound software in different formats already (.aif .wav .mp3) but no luck.

I tried exporting from Premiere and Audacity already, no luck.

Anyone has any idea of what might be happening?

Thank you for taking your time to help me :slight_smile:

Please… this is kinda urgent… I’v having production delay because of this problem, I can’t fix it…

I don’t know if it helps but in any case here is a picture of the sound editing window. This sound should have wave forms, it just shows like it’s a blank audio file.

http://img849.imageshack.us/img849/5379/nosound.jpg

anyone??

Well I have animate pro, not harmony, so not sure.

How long is your frame range? I imported sound the other day that appeared as a flat line, then I realized that I need to increase the time range before importing the sound, otherwise it will cut off anything past that.

It’s pretty big, at least big enough, around 150 frames… there should be sound in the first 2 seconds of audio already… I can’t figure this out, I tried everything.

I’m running it on BootCamp on an iMac

From a quick google search for boot camp imac audio issues, it’s seems that many users experience audio issues while running boot camp – I’m guessing therein lies your problem. Have you explored that?

I did search but couldn’t find anything regarding fixing this issue :frowning:

Hi, There,
Try to delete the tmp audio folder
C:\Users\User Name\AppData\Local\Temp\ToonBoomSessionTempDir\audio
Thanks
Wei

Hey,

I did that but no success… When i import audio it doesn’t even analize the audio, just slaps on an audio layer with a flat waveform.

:frowning: I’ve been trying for almost two weeks to fix this problem, tried different computers, I managed to make it work on only 2 of them. Couldn’t understand why though…

thanks for the help

Still looking for a solution

I’ve already installed and reinstalled the most up to date Audio Drivers… still no luck…

This Software seems to behave in a totally different way each machine I open it… very frustrating.

Hi, There,
Please download the latest ffmpeg, and replace the ffmpeg.exe file under
C:\Program Files (x86)\Toon Boom Animation\Toon Boom Animate 2\nt\bin
Here is the latest for Win 7 64bit
http://ffmpeg.zeranoe.com/builds/win64/static/
You need to decompress it and it’s under bin folder.
Best regards,
Wei Huang
Technical Support Specialist
Toon Boom Animation

I have the same issue with my audio files I import into my scene. Flat line and no sound. I’ve deleted the audio files in the Toon Boom audio folder, re exported my audio to different audio types, and even went as far as reinstalling Harmony. And still I can’t seem to fix my audio issue. Anything I can do? Is it my sound card?

Hi,
this helped me, fighting with the same problem for the last 24h:
Before importing, close other applications that use the sound card (iTunes, QT etc.). Then, my sound was also very low on the volume side, resulting in almost invisible waveforms, but the difference to the flat line before was immediately visible.
Hope this helps.
Hope TB would find out about that stuff before we run into difficulties.
Been hoping for years…

I’m running Windows 8, with all the latest bells and whistles including the new Harmony, and I’m having the same problem. I’ve been told the 32 bit floating is an issue, but I’ve tried different compressors from Audacity to do a fixed PCM 32, 16, 24, even a 64 at 44 to 48bazillion hz, and nuthin’.

I’ve closed all competing programs including any players or sound editors after saving, saved in different locations from Desktop to Music in My Documents, changed my default players, made sure temp files were deleted, used older versions of the same Harmony scene before any sound was even attempted at importing.

Nuthin’. Flatline, no sound, and I’ve done all the simplistic stuff like make sure the ‘Waveform’ was selected, cranked up the volume and the waveform to 900% . . . not a peep.

Never had any problem like this when I exported exactly the same way into Animate Pro 2 running Windows XP. I’m beginning to feel as though I should have NEVER upgraded. I’d be real happy and 1600 bucks richer if there was any happy ending to this story, or if there’s something that I’ve also missed that might solve the problem as well, because I’ve lost about three days just searching the net, these forums, and my mind trying to solve what used to be straight-forward, no-issue, no-problem with recording my own voice-work and putting into Animate Pro2.

That’s exactly what my window looked like . . . now, about 35 times just tonight alone . . . and my comment is at the bottom in full. I would like to know the same.

The comment by the Wei the tech is right. The fix is in the fact that you have to download the ff file, and unzip it. Trouble is, what was missing was the details as to why and how.

It worked for Windows 8 for Harmony 10, though I can’t speak for Animate Pro 2.

Harmony, by default, loads into my Windows(86x). So does Toon Boom Animate Pro 2. But there are two versions of win there, win32 and win64.

After searching the ‘Stage Guide’, I found nothing. But, when I searched the 'net, I found something that is noticably absent from the guide. There is a wee note in the beta notes of Harmony . . . not the guide . . . on the release of Harmony 10 that declares “. . . for users of Linux, for reasons of licensing, there is no ffpeg.exe included with Harmony any longer. Users have to download the latest version and install it themselves.”

By extension, not sure if that applies to Toon Boom Animate Pro 2 . . . I never had a problem with that program before myself.

Anyway, I opened up the link, and at the top of a very long and dry-looking list entitled ‘INDEX OF ‘builds/win64/static’ of plain ol’ programming text is a zip file that says simply, ffmpeg-latest-win64-static.7z’, and all the files on the list are dated, this one is clearly, by virtue of its’ date, the newest update. I had no idea which one myself to download, but I assumed that it had to be the newest version, so I saved it to my ‘Downloads’ file.
This is the way I did it, step by step:

  1. Download the file. Make sure you’re running your computer as ‘Administrator’.

  2. Unzip in ‘Downloads’, because even as the Admin, any free zip program (I use 7zip . . . it doesn’t try to install toolbars and garbage on my Explorer window) doesn’t have the authority to unzip it in win64.

  3. It all unzips into one folder, nice and neat.

  4. Then, open another window in your computer, find the Program Files (86x) on C: drive, open up ‘win64’ (there should also be a 'win32, but ignore that one), and open up the folder simply marked ‘bin’. All your Harmony and Toonboom-stuff (if you have more than one program) is there. Simply drag and drop the file from Downloads into that open directory, close the windows.

  5. I don’t know if this is necessary, but I’m used to having to finish any install with a restart, so I restarted my computer, didn’t have to save any work or anything. I immediately opened Harmony after restart, I grabbed the sound file .wav like I always used to with Animate Pro 2, and imported it just using the ‘File’, ‘Import’, ‘Sound’ sequence.

  6. Sound was there, in the Timeline, with waveform. No extra stuff to do. Tried it, worked just fine.

Anyway, that’s the process of searching and figuring out stuff that I went through to get those steps. I’m a very linear thinker/person, and I’m a person who likes instructions to follow . . . and where to get them. So, since this has been an issue for a lot of Harmony users I’ve noticed on the web, I thought I’d post this up as per how it worked for me with Harmony 10.
I never had to go to any extra ‘sub-directories’ in ‘bin’, I just dropped the whole unzipped folder in ‘bin’ where all the Toon Boom stuff was. I didn’t have to delete any ffmpeg files, so for users of Harmony that never upgraded or did a clean install of Harmony on a new hard drive like I did, the file/directory Wei mentioned won’t be there. It will just be Program Files (x86)/win64/bin.

Drop, close, restart, have a beer and sigh with relief.

. . . used other formats as well. MP3 (which suck for sound quality and lip-syncing for long clips because they’re not ‘lossless’), Apple stuff such as the .aiff’s, and a bunch of stuff that I literally just ran through the list out of frustration. Just to whittle down the list a bit.

I’d say I’d do this publically, so I will.

“I’m a moron”

Ignore my previous ranting, and continue to enjoy your Toon Boom stuff. It is a good program, but I sure wish I could buy a product and not have to download or install so many add-ons. I only took about a month of C++ before I realized I was an artist and not a techy, so I tend to like my toys assembled.

Thanks for the link to the ffmpeg files. I didn’t have any old ffmpeg files to delete because I did do a clean install of Harmony on a new drive, but it was enough for my poor old brain to figure out.

I’m sure some folks are rolling their eyes at the plight my inability to connect the dots (politely, of course), but I’m the sorta person that can sometimes spend hours trying to sort through something someone else can do in ten seconds by hitting the right button or finding the right menu.

I’m just thrilled to have my ‘auto-lip-sync’ back.