solved - Display All Mode, Adding Pegs & Rigging

When I try to add a peg to my drawing layer it says “Cannot add peg in this display mode. Change to Display All mode.”

I’ve tried googling and looking on these forums but I’m not sure where the “Display All” button/mode is.

If anyone could point me in the right direction or to a detailed rigging tutorial I would thank you!

using toonboom harmony premium

(additional information)
I’ve been following many tutorials on rigging a character for the past couple of days. However they usually only cover one part of the rig so I need to jump from tutorial to tutorial for each body part and facial structure then not knowing how to attach them and need to start over. Everyone seems to work differently with toonboom so I haven’t made much progress ^^;

Sorry for being a newbie at this! and thankyou for your time :slight_smile:

don’t select a Peg, select a Parent Peg from the Timeline pulldown select menu with the + icon otherwise you will get that message you can’t add a Peg, watch this tutorial it’s pretty lengthy though but thorough https://www.toonboom.com/resources/video-tutorials/video/harmony-11-how-build-cut-out-character at 23:40 it talks about inserting a Peg to Drawing Layers but watch the whole video, for a Cut-out Character each Drawing Layer should have it’s own Peg

Once place you can see the Display All option is just above the timeline on the left hand side.

thankyou! this helped alot!! :slight_smile:

thankyou!

I tried DessieX comment, but the Display Mode doesn’t appear unless you go to the Main menu and click on Windows select Toolbars and select Display to make that option appear, then you can select Display All, don’t know why it doesn’t come loaded already without having to go add it manually

the problem is solved I was pressing peg instead of parent peg :slight_smile:

thankyou again

Just be aware that when you’re on display all mode you’re seeing all elements even if they are not connected to the composite. That means that those elements will not appear on final render even if you see them on camera. If you export a movie you need to select ‘display all’ from display source. If you work with the Node view that shouldn’t be a problem, but if you work mainly with the timeline you should be aware of that and to the fact that creating drawings via the timeline with display all selected will mean that the drawings will be disconnected from the main composite and you’ll have to connect them manually (via Node view or right-clicking on the timeline then select ‘connect to composite’)


Luis Canau

thankyou :slight_smile:

Thank you MetalVagabond, this is what fixed it for me.