Should layer opacity and such be this hard?

Hey there, new to using Harmony and practicing with it. I’m used to using TVPaint because that’s what my university (stupidly) had a license for instead of ToonBoom.

In general, I’m in total disbelief at how such seemingly simple tasks are so cumbersome and counterintuitive compared to, say, Flash.

Specifically though, I’m trying to ink/clean up some rough drawings, and for the life of me I can’t figure out how to change layer opacity to help do it. I tried opening up “layer properties” and adjusting opacity that way but it didn’t work, and now that option is greyed out for me for some weird reason.

In TVPaint you have an opacity slider directly on the layers which is very practical. In Toon Boom the concept is different because as long as you have the light table enabled, when you select a layer and a drawing tool all other layers will became washed automatically, allowing you to clean over roughs, etc. Light Table should be enabled by default - it’s the yellow light bulb icon on the bottom left of your Camera View or on top of your Drawing View (this might vary according to workspace configuration).

You should also have a Top Light icon on top of the Camera or Drawing View. You can adjust the Light Table opacity there. If you miss any icon on a tool bar you can right-click on the top of the window and select Customize… below.

http://sn.grogue.org/lcanau/animation/img/light_table.jpg

The opacity via the layer properties is for more advanced use and flexibility, so it’s not as direct, but it should work also, the thing is it’s “destructive”, that is you have to change it back to 100% before rendering the scene, while the Light Table is just a view mode that doesn’t alter the layers properties.


Luis Canau

I’ve run in to a similar problem. I have a few people who do animation on paper, and then clean it up in toonboom. My solution to make the drawing transparent so you can scale it to the background is to just use a ‘transparency’ module. I don’t know if you have access to the network, but if you do just drag one in from your node library, and alt drag it into the cable. Set it to… I think it was 70? It’s always backwards from what I expect.

Here’s the help on that:
http://docs.toonboom.com/help/harmony-14/premium/reference/node/filter/transparency-node.html?Highlight=transparency

If you just have the time line, you can still put in transparencies I think. Yep! Here’s how:
http://docs.toonboom.com/help/harmony-14/essentials/reference/node/filter/transparency-node.html?Highlight=transparency

If you’re not getting the behaviour that Luis was talking about, I think you turn it on in your preferences>drawing by selecting ‘Light table: shade in camera view’.

http://docs.toonboom.com/help/harmony-14/premium/preferences-guide/drawing-preference.html?Highlight=light%20table

Hope that helps!