Shortcut keys randomly stop working

I’ve been noticing this problem a lot recently. I’m currently using Toon Boom Harmony 20 Premium and have been for the past year. Sometimes some shortcut keys would just not work, no matter what I do, and yes I do make sure that the workspace is highlighted in red before I do anything. It’s not all shortcuts that stop working, it’s completely random. Yesterday my cutter shortcut stopped working, earlier it was fixed but then it stopped again. Now the space+mouse shortcut no longer works and it’s becoming a pain to work, I’ve also restarted 2 times already. I’ve been experiencing this sort of problem for the last few months and I’ve grown tired of it. What might be the reason for my problem? And is there any way I can fix it?

If specs matter, mine are:
Windows 10 Pro 64bit
AMD Ryzen 9
32 GB Ram
GeForce RTX 2070
476GB SSD (Where my Toon Boom is stored)

I’m also using a Huion 640p drawing tablet and I use the shortcut keys there combined with the keyboard.

I’m also having this issue, which I hadn’t experienced before. The most egregious offender is Centre on Selection not working in the Timeline View, even though it works fine in the Node View. It was working for a while, then randomly stopped working. I’ve tried deleting the shortcut key, resetting the shortcut key to the original, and assigning it to another key, but it’s just straight up not working. It’s causing a really big workflow issue.

I’m on Windows 10 and am using Harmony Premium v20.0.5. I’m working on a stuido project, so upgrading to 21 isn’t an option. I’ve also tried restarting Harmony, rebooting, and reinstalling Harmony twice.

Update: it seems the shortcut does work with some parts of my project, but not with a specific rig I’ve been working with. The Centre On Selection button is also grayed out when I select the same part of the rig that the shortcut won’t work for, so I think there may be something else going on in my project. Going to do some more investigating and report back.

Nothing appears locked on my rig, so I wonder if there’s something else going on somewhere.

I was having this problem too, unfortunately i couldnt pinpoint when or why my shortcuts decided not to work. The only soloution i found was to reset my keyboard shortcuts and that fixed it for now. Good luck!