Shortcut keys randomly stop working

I’ve been noticing this problem a lot recently. I’m currently using Toon Boom Harmony 20 Premium and have been for the past year. Sometimes some shortcut keys would just not work, no matter what I do, and yes I do make sure that the workspace is highlighted in red before I do anything. It’s not all shortcuts that stop working, it’s completely random. Yesterday my cutter shortcut stopped working, earlier it was fixed but then it stopped again. Now the space+mouse shortcut no longer works and it’s becoming a pain to work, I’ve also restarted 2 times already. I’ve been experiencing this sort of problem for the last few months and I’ve grown tired of it. What might be the reason for my problem? And is there any way I can fix it?

If specs matter, mine are:
Windows 10 Pro 64bit
AMD Ryzen 9
32 GB Ram
GeForce RTX 2070
476GB SSD (Where my Toon Boom is stored)

I’m also using a Huion 640p drawing tablet and I use the shortcut keys there combined with the keyboard.

I’m also having this issue, which I hadn’t experienced before. The most egregious offender is Centre on Selection not working in the Timeline View, even though it works fine in the Node View. It was working for a while, then randomly stopped working. I’ve tried deleting the shortcut key, resetting the shortcut key to the original, and assigning it to another key, but it’s just straight up not working. It’s causing a really big workflow issue.

I’m on Windows 10 and am using Harmony Premium v20.0.5. I’m working on a stuido project, so upgrading to 21 isn’t an option. I’ve also tried restarting Harmony, rebooting, and reinstalling Harmony twice.

Update: it seems the shortcut does work with some parts of my project, but not with a specific rig I’ve been working with. The Centre On Selection button is also grayed out when I select the same part of the rig that the shortcut won’t work for, so I think there may be something else going on in my project. Going to do some more investigating and report back.

Nothing appears locked on my rig, so I wonder if there’s something else going on somewhere.

I was having this problem too, unfortunately i couldnt pinpoint when or why my shortcuts decided not to work. The only soloution i found was to reset my keyboard shortcuts and that fixed it for now. Good luck!

I am having the same problem and have for a while now. It has gotten to the point where I literally have to rebind every key that requires pressing two keys eg. ctrl c for copy. It’s not exclusive to two key press combo’s though as my return/enter key no longer let’s me quick search nodes unless I rebind it on start up.

This is extremely frustrating because every time I shut Harmony and reopen it I have to rebind at least ten different keys that I use regularly to get them to register.

I read somewhere that this could be a mechanical keyboard issue which I’m using but I don’t have a reg keyboard to test it out. I can’t believe this is still happening as it seems to be a widespread issue that has existed for a long time and is incredibly inconvenient and a hindrance to productivity. I love Harmony but it sure does make it hard sometimes.

I don’t really understand the point of the Toon Boom forums since nobody ever seems to reply with a solution, but I’ll commiserate with you guys.

I’m having the same problem. The worst offender is “center on selection” and it’s slowing me down considerably. I have a pretty complicated rig :frowning:

2 Likes

Are your keyboards natively in English or are they in another language.

When using a Non-English keyboard, it somtimes happens that a shortcut made in Harmony makes your keyboard language switch to English.

This means that Harmony won’t receive anymore the keyboard shortcuts you think that you are making, as your keybaord will be interpretted as if it was in English.

Might this be the source of trouble for anyone?

How are you editing you shortcuts, are you making your own NEW set or modifying the default (Toon Boom Harmony)?

The only fix is in Harmony 21.1 from the Release Notes

  • Loading a keyboard shortcut set makes default shortcuts stop working. HAR-8025

My keyboard is in English. How ever there is a combination of buttons that I can press to change it from English to English Australian. Is it possible this is the source of the problem?

Hey Steenbeck. I am editing my keyboard shortcuts by loading the “Toon Boom Studio” key set and then modifying those further by manually changing a few.

“* Loading a keyboard shortcut set makes default shortcuts stop working. HAR-8025”

Does this mean the default keys of the loaded set stop working, or the default keys of the original “Toon Boom Harmony” set?

How could I get around this if I wanted to use the TBS set and can’t load it? What a mess.

I take it as the default keys of the loaded set.

I have my own custom (NEW)set made off the Toon Boom Harmony set, all my default sets are unmodified.

i just had this problem myself. tho I was able to figure it out.

Try going to edit > preferences > perference set (at the top of the box) and open the drop down menu. That click rigging

this worked for me so I hope it works for you. good luck

1 Like

That didn’t work for me :frowning: but thanks for your input.