Select tool Keystroke


I’m having a problem selecting the Select tool in drawing mode in Animate 2.

I set it to “V” to emulate Photoshop.

In the menu Drawing/Tools “V” shows up beside “Select” as the Keystroke.

But when I push “V” the tool doesn’t change.

All the other keystrokes in the menu work correctly.

Can you tell me why this doesn’t work?

When you set the shortcut, did you select “Duplicate” or “Replace”? You should make sure that you select “Replace” so that it gets rid of the other shortcut that it has a conflict with. If you did Duplicate, then both shortcuts will exist, and there could be a conflict between them.

You can try to hit the Restore Defaults button and set the shortcut again, making sure to hit Replace.

Toon Boom Support

I’m also using animate 2, and I have problems with customizing shortcuts for most of the drawing tools in the drawing view.

I have tried to make the select tool ‘v’, the eraser ‘e’, the brush tool ‘b’, the paint bucket ‘k’, and the cutter tool ‘x’.

The only shortcut that Animate’s been successful in reading is ‘x’ (x was already assigned to another command, so I had to replace it).

For some reason, the program seems to hate assigning the letters I mentioned above, to the tools I mentioned above. When I assign those tools to any other keys (eg select to ‘1’, brush to ‘2’, etc) - they work, and continue to work when I close and reopen the program.

However, when I assign those tools to V, B etc… they refuse to be recognised, that is, when I press V, select does not happen. I am also aware that there are 2 brush shortcuts available, brush tool, and brush tool (general). I have tried modifying each separately (one blank, the other with the shortcut, and the other way round) and both together with the same shortcut).

Every time it asks me if I want to ‘replace’ or ‘duplicate’, I hit replace. I have also tried duplicate just for the hell of it.

The really frustrating thing is that there are instances when I have found the shortcuts to work:

1. I set up all the shortcuts, tested them out, surprise surprise they don’t work. closed the program, reopened it and tested the short cuts. they still don’t work. I go into preferences and clear my non-working shortcuts. there is now NO shortcut assigned to brush and eraser. I click ok and suddenly, when I press ‘B’ or ‘E’, my brush or eraser is selected (now this doesn’t even make sense! but i’ve tested it twice. it must be a bug.).

2. I set up the shortcuts one at a time. For the brush, I cleared both shortcuts for brush tool and brush tool (general). I made brush tool (general) into B. I click ok and test it. It works! I work for a bit, thinking I’ve solved it. I close down the program and when I reopen it, ‘B’ no longer works. I try ‘x’ to activate the cutter tool, a shortcut i customized earlier, and it works. i go into preferences, thinking that it’s deleted my brush shortcut. but it’s there, exactly the same as it was when it was working. I clear the shortcut, then set it to B once more. it works! however, when I restart toonboom again, I run into the same problem. Talk about annoying! Everytime I go into the program, I have to click on my shortcut, clear it, and retype it in for it to work.

To be clear, this only happens for the select tool ‘v’, the eraser ‘e’, the brush tool ‘b’, and the paint bucket ‘k’. I suppose I could just assign these tools to different keys - but then what would be the point of customizing in the first place? I’ve wasted 2 hours fiddling and experimenting with these shortcuts - if this is a bug, is there any way it can be fixed?

After going through the other pages of the forum I see others have had this problem and someone suggested to click ‘default’ to reboot the shortcut, then click ‘replace’. i’ve gone through and done that and all the shortcuts now work, which is great.

However, I now realise my shortcuts were probably working all along - but I was getting confused because my drawing view was selected when I was trying to access these shortcuts.

I’ve found that the shortcuts still only work when the timeline is the active window, then I can toggle through B,V,E as much as I want. The problem is, I use these tools in my drawing window, and whenever I need to use a different tool, the shortcut Doesn’t work!

Is there a way to make my shortcuts work in drawing view? There must be, because I notice that my ‘x’ to select the cutter tool still works no matter what window is selected. Another weird thing: I tried clearing the brush tool and adding the shortcut again, and it worked! both in drawing and timeline view! when i reboot the program though, it no longer works. gah.

The way that the software was prrogrammed is the following. For a tool like the brush tool, the shortcut is Alt-B. There is then a hidden shortcut there that states that if you push B on its own, you get a temporary brush tool that lasts as long as you hold the button down. This is the same for all the tools - for Alt-E for the eraser, if you push E it gives you a temporary eraser that lasts as long as you hold the button down.

Because that is something that is hard-coded, if you try to switch tools by only pressing B or E, there may be an internal conflict that can’t be resolved.

There’s nothing that can be done to change this at the moment. I will submit this as a feature request. The best that I can offer is that you try clearing out and restoring defaults again, and see if that helps.

Toon Boom Support

Hi Lilly,

Could you please post a list of the Animate Pro 2 hidden shortcuts for us? I don’t see them listed anywhere in the docs.

Thank you for your help,


look for the file Animate_Keyboard_Shortcuts.pdf. It lists the default keystrokes. on my mac, it is in the Animate 2 folder, then Documentation,

Thanks Mike. I was actually looking for the “hidden” shortcuts that Lilly mentioned, such as “b” for temp brush tool, which aren’t listed in that PDF. After re-reading her post I see that it’s only the tools that have hidden shortcuts, so I can deduce what they are.

I apologise for not being able to get back to you earlier - I’m travelling through India right now :slight_smile:

As you have guessed, it’s all of the tools that have these properties. Basically if you go into your shorcuts and find the tools’ assignments, you will see that all of these are assigned a key like Alt + something. Each of these tools has a non-Alt version that is the temporary version of the tool.

I don’t think there is a list of them, but hopefully you were able to resolve thsi question on your own.

Toon Boom Support

Thanks Lilly!