Runtime error, usual fixes not working

Hey everyone! TBS works fine until I try to import an image, then I get the runtime error. I searched around and tried the usual fixes (drivers, redownload, switch out of OpenGL, turn off Aero) but nothing seems to do anything.

Here are my relevant pc stats:
16gb RAM
GTX 970
i7 2700k @ 3.5GHz
Windows 7 64 bit

Drivers are up to date, my specs are fine, and it is not even reaching 25% utilization for anything, so it shouldn’t be a problem here. The project itself is tiny (literally blank and then trying to add any image just to test this). Any thoughts on what the problem could be?

What are the details of the runtime error?

Be aware that on Windows 10 that Quicktime 7.7.7 and 7.7.8 are broken.
You would need to install an older version.

I get:
Runtime Error!
Path to TBS.exe


  • pure virtual function call

I’m on Windows 7 still, but I will check out my quicktime anyways and see if that is the issue. Thanks for the reply!

Sometimes runtime errors are caused by security software blocking stuff.
The really aggressive ones are Norton/Kapsersky/McAfee.

It can help to uninstall the antivirus in such a situation, along with TBS
and Quicktime. After that reboot and re-install TBS along with Quicktime.
Run TBS and Quicktime at least once before re-installing the antivirus program.
They’re a lot more lenient with stuff already installed.

So I tried your suggestion of rolling back to 7.7.6 and it didn’t do anything for me.

The only antivirus/firewall I run is the default Windows one, and it has no exceptions or anything set to block TBS. Considering it isn’t exactly meant to be uninstalled, I feel it isn’t the issue. In the meantime I will add another exception to make sure it is allowed through the firewall and reinstall TBS to see if that changes anything.

EDIT: So after this reinstall it worked! Perhaps it was because I reinstalled after rolling back the Quicktime, or because of the exceptions added to Windows Firewall, or something else. Also worth noting that the last few times I (re)installed TBS it took forever to do so, but this time it was really quick - maybe I just had bad luck with the last few downloads even? Either way it works now!

Thanks a bunch. :slight_smile: I hope this comes in handy for anyone else in the future.