Render cache

I’m working on a 320-frame animation, the basis of which is a series of .TGA images converted from some video footage. The project resolution is 1920 x 1080pix.
My first problem was that when exporting, either via Play|Render and Play or via File|Export||Render Network, the process appeared to complete, but actually stopped at around frame 210.
I’m also getting repeated but unpredictable problems during preview & working on the timeline, where Animate PRO reports that read operations could not be completed.
To try and solve these issues I attempted to use the Render Settings, enabling image caching.
I typed in an existing directory path in the following form, as instructed in the User Manual:
I also tried entering it with an initial semicolon, as per the Preferences dialog box.
In both cases, when launching the application, I get the message that the cache directory is invalid, and that the application temp directory will be used.
At least, enabling the cache allows the render to complete, but I still cannot play using the preview player - frames beyond about 210 are apparently loaded, but instead are inserted as blanks.
But I would like to know why the pathname is rejected.
I’m running Windows 7 on a machine with INtel 17 dual core processor, 4G RAM.
Any ideas?

Thanks for your suggestions, Lilly.
Can you explain what the entry should be if it is not to contain semicolons? Both the User Manual and the example given in the dialog box contain semicolons.
Yes, the folder exists.
Luckily, as I said, Rendering works when I export the network. In this case it is fine, because I want to preserve an alpha channel, so am using TGA4 file output.
I have tried with a different animation of 528 frames, containing only a few frames of image info, with the rest relatively simple vectors, but using a blur effect. The same happens when using Render & Play; at about frame 210 the process appears to complete, but contains only blank frames from then on. The soundtrack is exported complete.
I intend to upgrade to 12G of RAM, but would be surprised if that is the only problem. I have a massive amount of disk space free.

I think the filename is rejected because it contains semi-colons (;). Does the folder where you’re trying to save exist? Can you browse to that folder in a file browser?

Likely your system is running out of memory and that’s why it gives you blank frames. If you disable or delete your image layer, does it play back better? If you do a full render, does it render blank frames there as well?


Oh oh I’m sorry it’s not the folder that’s written that way - it’s the folder then the amount of disk space in semi-colons. Excuse me! This is what I get from trying to do too many things at once.


I’ve seen it render black frames before when it’s run out of memory on a given frame if there are too many effects on that frame. If you take the render and play and apply it from frame 210 to 300 for example are you able to see that frame now? Or is it still black?

If it’s always black, then that indicates to me that there’s something wrong with the actual render. If it’s rendering fine if that’s the only image that you’re trying to render, then that to me indicates that it’s running out of memory.

I’m still concerned that there’s something wrong about the name of the directory if you’re getting an error that the directory is invalid. Are you able to browse to that directory in a file browser with no issues?

There are no special characters in your filename so I wouldn’t think that is the issue.

I’m looking into this one right now and I’ll get back to you as soon as I can on it.

Or you can always email for additional help as well.


Okay so I’ve done some further investigation on this one and your render path should look something like this:


So looking at your example, you should leave off the last backslash and the last semi-colon and it should work.

When it comes to doing a render and play, you might consider setting up a test resolution that’s half or a quarter of the size of your final resolution. You can switch to this smaller resolution for running tests on effects and animation, then you can switch back to the full resolution when you do the final render.