Render and Play window spawns 3/4ths offscreen consistently

Hello friends!

Getting going with Harmony 20, having a lovely time thus far.

Something I’m having an issue with, every time I click “Render and Play” (our handy Play button with the star on it above the timeline), it spawns the “Toon Boom Harmony Play” window three quarters off the screen relative to the other windows. Is there a preferences menu fix for this that I’m not catching? Otherwise can this behavior be adjusted in the registry somehow?

Screenshot attached!

Thank you!

-Justin