Hi Jen,

The right clicking bug has been fixed in the path we released a few weeks ago. I sugest that you install it if this is anoying.

The lost of focus when using a wacom tablet is a bug that we didn’t fix yet but that we will fix ASAP. The keyboard shortcut bug is related to the window focus bug.

I also would like toi know if these are affecting many users. Please write back if you encounter these bugs frequently.

Thanks for reporting. I will make sure these get fixed.


Phew! For a while I thought it was just me. I’m also having the issue with the right-click myself.

I’m in the middle of a project. I completed one scene with the right-click working fine. As soon as i started my second scene …it started to act up. I have stopped all work now because I’ve already lost some work when this happen … luckily it was’nt a lot. I spent hours trying to fix this …thinking it was my system (rather than the software). Its kinda sad …but I felt relieved when I saw this post.

I like this software … but one click …and you loose hours of work …not cool!

I have the V3 version, and I downloaded it the first week of its release …is there an upgrade or patch available for this now?

Yes there is a patch for the right click problem and some other issues on Mac computers.

It’s at the same download page then the regular TBS V3 build. Visit the members section and click on your V3 license key to access this page.


I got it working …here’s how.

My right-click issue began when I tried to use cut/copy cell and paste feature. After downloading the new patch …it still crashed when I tried to use the right click initially. However …I did one cut/copy paste using the toolbar. After doing that …I was able to right-click at will without any problem. Its not “THE FIX” we need …but it may help. Try doing whatever you were attempting to do by right-click using the tool bar first. Then try right-click and see it it works.

Also I was surprised to see that many bugs when I read the note prior to the patch. Guys …this is a great program … you need to fix those problems ASAP.

Hi All,

Ok, this is probably a different right click issue then the one addressed in Build 3.0.68.

I’m trying to reproduce this bug on my computers. Can you guys help me and tell me:

What OS you are using (if possible the exact revision) ?
Do you use a Wacom ?
How many scenes in your projects ?

If possible some exact steps to reproduce. As soon as I can create the bug I will be able to try to fix it ASAP !

Thanks for your help guys !!!


Hi Jennifer,

Thanks, can you tell me what video card are you using ?


Hummmm … can you try to change the display settings to OpenGL and get back to me. I’m pretty sure this will help !

To change this setting go to the Edit menu => Preferences

Click on the displya tab and change Direct3D to OpenGL.

Did you install the driver from for your card ?


Did you restarted TBS after switching from Direct3D to OpenGL ?

I can’t reproduce this bug here, I’m right clicking everywhere and I’m using the Element menu without any problems.

I’ll just wai t a bit for more inputs on this tread. I’ll do more test later.



Sorry to hear the problems you are having … I have felt the same frustration myself.
I said I fixed it previously …I lied! Not only does my right-click NOT WORK in my scene2 …any click on the tool bar element tool …and the program just SHUTS DOWN!!
Even if I wanted to draw I couldn’t even change the exposure of each frame.

Just one question if you don’t mind …when you draw …are you using the pencil or the brush tool? I ask this because months ago I almost threw my brand new machine out the window because I got so frustrated when I drew anything wiith the pencil tool. Something I prefer to use because I didn’t want variability in my lines when I draw with my tablet. To date I have not fixed the problem …and no longer try to use the pencil tool. The issue was, when i used the pencil tool and then try to replay just a few frames the speed of the playback slows down …and my CPU resources max out. This happen if I drew just 3 stick men on 3 frames with the pencil tool and try play it back in a loop …with no other application running… on a brand new machine with a 256 Nvidia card, AMD-64, 1G memory.

Finally if you fix your problem can you tell us what the problem was …it may help myself or someone else.

TBS need to think hard about their approach to doing business. You guys don’t sell people a program and think you can cover your ass my placing a note saying …ITS NOT FOR PRODUCTION!! >:(

Thats like selling me a car and then telling its not meant to be driven on the street! Grow up folks …YOUR PRODUCT IS BEING USED BY ADULTS!! I really believe that these people do not recognize that.

TBS take pride in being a traditional animation tool…you brag a about not providing any 'tweening feature! So at the end of the day the last thing anyone need when they know they have to plow through every single frame …is to struggle with a buggy program!!

Right now I’m stuck myself. I can’t do anything in scene 2 …and I fear screwing around and loosing scene 1.

Maybe now is the time to start exploring MIRAGE!!!

It costs twice as much as TBS …but even 3 times the cost will be worth avoiding this agravation!!

Hi guys,

I actually find out last night that the latest wacom driver cause most of the keyboard shortcuts problems. Downgrade to 4.87 instead of using 4.91.

Also, I was told that some right click problems occurred when using DirectX and the newer NVIDIA video card on Windows. I’m not saying this is THE FIX for everyone but It can’t hurt to change the settings to OpenGL and leave it that way if you are using such a card.

Restart the application if you change the preferences.

Please try these two things and report back.

It’s not that I don’t want to help you guys, it’s that I need more information from this user community to reproduce this these bugs. I first need to know what is the bug and how to reproduce it before even thinking about how I’m going to fix it and yesterday I was not able to reproduce this problem. Since this tread is so popular I was expecting more people to send more information to help me find the problem. I think I found the keyboard shortcut bug yesterday night and I will continue to work on the right click problem.

Everyone’s input on the problem is appreciated.

This take more then 2 days guys, we had other issues in the past and we responded with a fix in a reasonable time.

Please believe that we do our best to solve this issue.

Thank you.

Thanks Jennifer,

This problem has to be hardware related. I did everything you are mentioned to reproduce the bug and still cannot make TBS crash with a right click ( tried for over half an hour today again).

You could help me by sending the system information report from Windows XP. This report doesn’t contain any personal information but only information related to the system (drivers, resources, hardware details).

To generate this report follow these steps:

click on the Start Menu => Accessories => System Tools => System Information.

A new window will open. On the left side select the top level title “System Summary” and click file => Export.

This will save a txt file with the report. Send it to me by email to

Also if you agree I would like to send you an ftp link in replt to your email for you to upload your buggy project. Just to make sure it’s not corruption of data.

One more question, did you install the latest driver from for your video card ?

Your help to resolve this issue is appreciated.

Thank you.

TIGER, could you do the same for the system information report ? I’m pretty sure I will find a link between you two in this report. As far as I know only you guys have reported this bug. I can’t imagine nobody else would have had this bug since July 7. We have a lot of Professional customer who have upgrade and did not report.

Again thank you.

I am trying to help. Here are the specifics regarding my problem:

The system crash when I :
a) Right-Click on any cell of the exposure sheet in scene 2
b) Left click the element icon on the tool bar in scene 2

This means I cannot copy/paste, increase frame exposure etc.
I have 2 scenes so far …and in scene 1, I do not have this problem…if …if I try these functions in scene 1 …before switching to scene 2!! Once I switch to scene 2 …right-click is messed up everywhere. And when I attempt to do this the system just shuts down immediately…with no warning …and you loose any work that has not been saved!!!

Scene 1 has 550 frames, scene 2 has some 50 frames.

I am running Windows SP2 on a 5 month old machine.
-AMD Athlon 64
-1G ram
-80G hd (with 65G free) at 7200rpm
-128MB Radeon ATI 8X AGP card.
- I am using a graphire3 tablet with version 4-84.6

I have kept my old computer …because i want to limit the amount of contact my new machine has with the internet for fear of contracting any virus. This machine is clean and uncluttered, with ample capacity to run TBS.

I download and installed the patch from your website on Monday (after first uninstalling the V3 original version)
I have the system preferences set to OPEN -GL and de-activated the “hardware acceleration” .

If you have anymore question please ask …I have a day job, so my time during the week is limited. I mainly work on this during the weekends … and would love to resume my work then.

Also …I was a bit dissapointed to hear you suggest the tablet driver may be at fault…because I’ve been down that torturous path a few months ago myself. Back then, I was trying to fix the problem I mention earlier with the pencil tool. And all I got was frustrated …and a resignation that the pencil tool is just unavailable to me.

Hope this help you help us.

Another thing to note is …it took a while for me to discover this problem. This is because I’ve had so many bouts where I start and then abandon work in scene1 for a myriad of reasons unrelated to any software issue. And those that I didn’t abandon …I was able to do with one scene. Its only now that I’ve done something in scene 1 and decided to continue to scene 2.
That may be the reason why many of TBS users have not encountered this problem yet.

Jennifer is actually doing billable work …un-like a casual user this should be a major issue for her. And a problem she would encounter right away!!

Thanks for your feedback Tiger. I’ll be working on this issue today!

I’ll let you know.


I had this problem working on a project. Now I’m able to easily repeat the problem by …just creating a scene 2.

If I open the application …create a 2nd scene …without ever creating a single drawing …right-click bombs the application.

I’m fine it seems …if I stay with only ONE SCENE.

When can we hope to see a fix on this? Has jennifer managed to fix her problem? Has anybody else experience this problem?

I have only the week end to spend any meaningfull time with this application and this problem has me shut-down right!

Hmmmn sounds like hell. I have had problems in the past that made working difficult like this. In my case it was kaydaras motionbuilder version 4. In the end it was a issue where the motherboard I had was using less than ideal components.(sis controller). It seemed very unreasonable to me that the software was so sensitive, no other applications had problems like this. I really hope this is not the case here.

I would strongly suggest if you havent done these things yet do them now. Defrag the hard drive, run virus and trojan scanners, run spyware removoers. And definitly get another mail client outlook is a invitation to disaster, try thunderbird it is fast, safe, and free.

Now I am currently not a owner of this product, I am demoing it. I am a animation student. The great majority of us use maya since the school is gared this way but many use other 3d and 2d solutions. I am primarily interesdted in TBS to do the very rough animation solving much faster than in maya.

So This thread was quite an alarm to me. I did do the steps tiger gave and to me it was fine. No crashing. But It seems that if I switch between layout and drawing mode I am experiencing intermitent pressure sensitivity loss. If I then tap the pen away it will work again. I did take the nib off and it was not dirty. sometimes this will cause trouble. I have no problems in other apps either. But beside this the version 3 program seems very good and I really like the timeline being available in both modes.

Ok if you read all of this sorry I went on and on… it is getting late.

btw my system specs are

win xp sp2
P4 2.8Ghz
2G ram
intuos 2 (driver 4.91-2)

Thanks for the feedback. Its a hard sell telling someone they have a hardware problem when TBS is the only unstable application on their system.

Also …if your demoing the software … are you running the same version we are? I believe the demo is a stripped down version of what they currently sell. :-[

I really do not know if it is different. Quite likely it is . Development is typically not as focused on demos. As far as I can tell the only difference is in the watermark and timelimit. I basically posted here just to keep the developers informed.

I wonder what wacom you are using? I know when the intuos3 was released there were issues in other applications. I thought it was addressed with a new driver within days though. I have to say I am now a bit hesitant to by this product. I really do not want to go through a kaydara situation again. I agree with you saying it is hardware related is not acceptable. Especially if the previous version was solid on the offending machine. ???

btw i forgot I have a nvidia 6800 with current drivers.

Thanks for the effort … I just wish the developers would spend their time trying to fix this “buggy” program before they try to sell it.

I cannot work with it now …and so I’m demoing MIRAGE and FLASH for the next few weeks. I’m leaning towards FLASH …love the relative simplicity when compared to mirage plus it does not HOG resources the way mirage does.

Can anyone comment on their experience with Flash … and please tell me which version of the application you’ve actually used.


I’ve just bought ToonBoom Studio and came on to this bug. It makes it unusable, since the shortcuts are lost. Ex: Z and X are for zoom in and out. After a while, Z is assigned to Previous Drawing…

Also, most of the time, the line I draw appears something like 3 inch below the pointer on the screen…

What should I do to fix this bug ? I swear ToonBoom is almost unusable with this bug for me.

And also, the ctrl-z (undo) gets mapped to “exit” after a while…

Thanks to look into this,


Hi Yanick,

Unless you have a graphire 4, use the driver before 4.90-3 (4.84 or 4.87). This should fix the problem.

If you are using the new graphire 4, only the 4.90 driver is supported.

We are currently fixing this problem and we will release an update to TBS 3.1 in a week or so.