Rain effect Z depth

I cannot figure out how to make the rain effect appear in front of my foreground layers. I use the default rain effect in the module library. It works well and shows up on top of all my layers that are at 0 z depth or behind. But if I have a layer that is moved forward, closer to the camera. the rain goes behind this layer. It looks odd since there is no reason why there should be no rain on this layer.

But I have tried moving the rain forward with a peg and it appears to be in the right position judging from the top and side view, but it does not appear on top of my closer layers. What can I do to fix this?

Are you using a template or the particle system?

I’m using the one in the Module Library/Particle Examples.

Okay, I will try have a look when I get home tonight. The problem intrigues me(plus i really like the particle system!). No Harmony on laptop today cause the licence is on my PC!

Well, I figured out a solution. I just moved everything back behind zero Z depth. The layer that was causing the problems was the one that was moved forward. So I figured if I couldn’t move the rain forward, I’d move the foreground layer back.

Still I wonder how, if at all possible, I can move the rain effect?

I seem to get the same results. In the perspective view, I can see the rain getting near the camera when I change the Z value of its peg, over an element with an higher Z, but in the camera or render view the rain is still behind that element. I guess you have to play with the elements not with the particle effects.


Luis Canau

You could do it by putting an Apply-Peg-Transformation module under the Rain group and attaching your adjustment peg to the left port of this module. It doesn’t work when you use the peg above the group.

That did it!–the first option you described. Thanks so much, Steve! This really had me stumped! Awhile back I did a commercial for someone that had rain in one of the scenes and, for the life of me, couldn’t get the rain to appear on any of the layers that were positioned closer to the camera in Z space. Now I know how to do it!

thank you too :slight_smile: I had tried a couple of times and it wasn’t acting the way I expected!

I just checked a bit more and you can do it also by putting a peg in the right-port of the Particle-Visualizer as explained in the Integrated Help for that module. It seems to work with my quick test.

Indeed, the way to do this is to use the Visualizer. Keep in mind that there are 2 ports here. The left Peg port will move the position of the entire particle system. The right Peg port will move where the flattened version of the particle system is composited.

So actually, you can also put a peg in the right port of the visualizer and move this forward. This will move where the particle system is composited, without adjusting the position of the overall system.

By the way, I am in the process of recording some Tips on Particles, so stay tuned for those in the next few weeks!

~Lilly