Quitting Unexpectedly during Export

My project keeps unexpectedly quitting during the export at about frame 120.
This happened a few months ago, and I was able to go to the bad frame and change things and make it run smoothly. In this case, however, I have hundreds of different things going on at said frame, and I’ll never have time to try deleting them one by one. Is there something else I can do?
It’s the most frustrating thing I’ve ever experienced (Not to mention this project is on a deadline).
~ Justin

Hey, I remember having the same problem back when I was using Animate (since I purchased Pro, I haven’t had similar problems).

My solution was to export 100 frames, then another 100, and so on… I had each scene in it’s separate file, so it was ok. When everything was exported, I just imported it into my video editing software and exported it to whatever from there.

Also, if you’re using Windows (don’t know how it is on Mac) open Task manager and under processes find Animate.exe, right click > set priority > high. This should speed up the rendering process, maybe it even resolves you problem completely.

Unfortunately, that’s all the advice I can give. If nothing else, try using it as a temporary replacement until you problem is resolved completely! :slight_smile:


Hi RWA,
I’d like to try this, but I got a pop-up warning that said “may cause system to become unstable”. Is that unusual?
Thanks,
Marty

RWA, thanx for the reply. I’m on a Mac though and didn’t find a Task Manager equivalent.

Lilly, thanx for your reply. I freed up 13 GB of disk space on my computer, so that should be enough memory, right?
It was quitting at the only couple of frames that had symbols in them. So I removed them. Any idea what that’s about?
Also, if I’m exporting as a Quicktime Movie, what KB/second do I want? It was originally set at 6400, but I changed it to 512, which I read in the PDF Animate Guide. Is that right?
Finally, the export is currently running, but EXTREMELY slowly – exporting about 115 frames per hour. It’s a 3400+ frame project, so I’m foreseeing over 30 hours of export for a 2-minute scene. Is that normal?
Thanx ~ Justin


Hi RWA,
I’d like to try this, but I got a pop-up warning that said “may cause system to become unstable”. Is that unusual?
Thanks,
Marty


It’s just a warning that always shows up, there shouldn’t be any problems. This cheap trick quickened my rendering from 45mins to 8mins, which was crucial when I was working under a deadline. Hope it helps you! :slight_smile:

Hi Lilly,
Here are the specs on my computer:
Model Name: MacBook Pro 15"
Model Identifier: MacBookPro2,2
Processor Name: Intel Core 2 Duo
Processor Speed: 2.16 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 4 MB
Memory: 2 GB
Bus Speed: 667 MHz
Boot ROM Version: MBP22.00A5.B07
Let me know if any other info. would be helpful.
Also, here are the settings my Quicktime movie export options are set to:
Compression type is HDV 1080p24
The frame rate is set to “current” (Which means 24, right?)
Key frame every 24 frames.
Frame reordering box is checked.
Data rate is “Restrict to 512 kbits/sec.”
“Size” is 1280 X 720 HD.
My sound compressor is “none.”
My “Prepare for Internet Streaming” box is checked, and “Fast start” is selected.
I’m obviously a writer/artist before I’m a computer wiz.
What settings should I change?
I’m on a deadline this week and need to get my exports to a reasonable speed (Like less than 30 hours for 3 minutes).
Thanx for all your help :slight_smile:
~ Justin
:slight_smile:

Hi Lilly,
I just exported another project that is all vector drawings and it went fine.
So I think my problem is with my current project, “Gumdrop,” which is all imported Photoshop Documents, rather than my system or settings.
Is there anything about PSD drawings that would massively slow down an export and even cause random Toon Boom quits?
Is there someone I could send the whole project to for a better look?

By the way, my graphics card info. is ATI Radeon X1600: (It’s a laptop, so I think it’s a chip set rather than a graphics card).
I tried changing my Quicktime “codec” to h.264, but couldn’t find that option under Quicktime preferences. Is that where it should be?

Thanx,
Justin

Hi Lilly,
I did find the H.264 codec but it wasn’t any better. Is there any way I can go to the project now and change the PSD images (There are 100s of them) to vector drawings? If so, would it change their look? (They’re crayon drawings, and we don’t want to lose that look).
Thanx again,
Justin :slight_smile:

Oh yeah, and if it helps, the error message I’ve been getting lately says: St9exception . Mean anything to you?

I set it to “all.”
I’m now thinking my Photoshop documents in my project are too big.
I think the largest image in the project (The background) is
8752 pixels wide and it’s 800 pixels/inch (But most are smaller).
How big is too big? What size should they be for a good animation?
Is there a way to change their size/resolution in Toon Boom?
There are 100s and 100s of them, so re-doing them in Photoshop
and replacing each in Toon Boom would take forever.

There’s no way I can do it in Toon Boom?
And should I convert the bitmaps to vector drawings in Toon Boom?
And what resolution do I need them to be? It’s currently 800.

Hi Lilly,
I went through and brought the resolution of all (100s) of my PSD images to 300. It seemed like it was exporting a little faster, but then it still quit unexpectedly about a half hour in. :frowning:

Then, I tried exporting it as a SWF and it worked this time (It hadn’t the time before) except for 2 things:
1) Exactly 1 layer was missing from the final result (A character’s wings) and
2) It displayed more in the frame than was in my Animate project
I SWF exported it again and had the same 2 problems.

Now, I don’t really trust SWF exports (Unless you know of a fix for those) and really want it to work as a Quicktime export. Would bringing the resolution of the images down further, say to 200, help? What resolution should they be?

Still trying to export "Gumdrop."
I’m now going back and re-importing all of my PSD images but vectorizing them on the import. That will help, right?
Here’s the new question. I re-imported and vectorized the 1st layer.
Then, rather than re-do all the keyframes (a nightmare),
I copy and pasted that previous PSD layer’s keyframes onto the new vectorized layer’s keyframes. It worked the 1st time, but then it didn’t work with the next few layers (The layer became invisible).
I’ve looked all around to see what I did differently but can’t find anything.
Any ideas?
~ Justin

I thought my main problem was that my images were PSD bitmaps rather than vector images? I’ve spent weeks re-building the whole project with vector images. It now exports in 8 hours, but I still have constant crashing problems and sometimes random layers are even blank in the final export. I am absolutely at my wit’s end. Is there someone way I can reduce the size of my vectorized images without losing quality? What else can I do?
~ Justin

Can anyone give me a crash course in optimizing? My project is all PSD bitmap images that I’ve now vectorized, but they’re still crashing my system. Can anyone tell me what the different optimizing features do, if they will make the images smaller (memory-wise), ups and downs of using them?:
- Flatten
- Smooth
- Remove Extra Strokes
- Optimize
- Reduce Drawing Resolution
It takes me so long to export, that i don’t want to try them one by one.
Thanx,
Justin

The question is, is it running out of memory, or is there some kind of issue on that frame. If you just export that one frame on its own, does it export?

~Lilly

Regarding the disk space/memory issue. When you free up disk space, this is not the same thing as the memory that is used up by the program. The memory we’re talking about in this case is RAM. Because we’re a 32-bit application, 2GB or more of RAM should be sufficient.

Freeing up disk space on your hard disc will simply mean that you can save more frames on your computer.

Effects are usually what will slow down the render time of your computer a lot. If you have many effects in your scene, then it just simply takes more time to render. The processor on your computer might also affect how quickly you can render.

What codec are you using for the Quicktime render?

Also what resolution is your project set to? If you render a larger resolution, like HD, this will take longer to render.

On my machine I tested rendering a scene that has some effects in it, and I rendered it in HD, and it took me about 4 minutes to render 100 frames.

What are the specs on your computer? What does it say in About this Mac? What graphics card do you have?

Do you get the same slowness of export if you export an image sequence?

~Lilly

Hmm I don’t have the same Quicktime codecs on my machine that you have on yours, so I can’t test that one. I usually use the H.264 codec, then I set it to Keyframe: All. Then I leave the data rate on automatic.

The only other thing it would be helpful for me to know about your machine is the graphics card.

When you change the “Size” in the Quicktime dialog, this isn’t taken into consideration - the resolution from your Scene Settings dialog will override this value, so just make sure that you set up your resolution in Scene Settings.

If you’re rendering with a bunch of effects in HD it may just be that it takes some time, but that does sound like quite a lot. What is your resolution set to in your Scene Settings dialog? If you change Quicktime codecs (try H.264 just for kicks) does it go faster?

Does it render faster if you render just an image sequence?

~Lilly

Definitely using all PSDs will slow things down. The reason is that vector drawings are much lighter than bitmap drawings, bitmap meaning any drawing that is a pixel-by-pixel drawing. When you use PSDs, it has to calculate the position and effects on every pixel for your project, rather than being able to do the computations mathematically based on curves like it would do with a vector drawing.

Using a lot of bitmap images will use a lot more memory to perform the operations.

I checked out the specs on your graphics card and it looks like it supports DirectX better than OpenGL, and we use OpenGL. It supports OpenGL 2.0, and we recommend OpenGL 3.0 or above. So it will work for most operations, but may be a bit of slowdown.

When it comes to rendering complex bitmaps with effects it might be better to try it on a desktop with a dedicated graphics card, but if you can’t do that then I would suggest just trying to export an image sequence, then take that sequence into a video editing software to do your final render.

If you wanted to try to export to H.264, if you go to File > Export > Movie, then click on Movie Options, then under Video click on Settings, there’s a dropdown list at the top for Compression Settings. What appears in this list depends on what you have installed on your computer. H.264 comes standard with the free Quicktime that you can download off the web. If you have any video editing programs like Final Cut, these might add additional codecs to the list that you wouldn’t have with the standard Quicktime.

I really hope you can get this rendered!

~Lilly

Oh sorry - and if you want to send the project to someone to take a look, then email support@toonboom.com and they can set up an ftp where you can drop your project.

~Lilly