question regarding template

hi all! i recently downloaded the game bone deformation template, and i had a question about it. in it, the character is broken down into top half and bottom half. if you have the template, you can see the right arm layers are included on the top half peg. however, when moving that arm with the deformer, it still will go BEHIND the legs of the character, despite the legs being on a layer below that, under bottom half. how is that happening, since the arm layers are above the leg layers?

here’s the template: https://www.toonboom.com/resources/templates/simple-game-bone-deformation-puppet-template

If you check the parameters of the TOON_arm_top_r-P by double clicking on the layer to open Layer Properties you’ll see that it’s set to 0.0080 B. You can also check the values on the Timeline opening the plus sign of that peg (you might need to activate the Parameters area of the Timeline by clicking on the second icon on the bottom left of the Timeline view). In the Timeline the x,y,z values appear as 0, 0, -0.008. This basically means the arm is back 0.008 on the Z axis.


Luis Canau

thanks for your help!

when i apply that to my own rig, it places the layer below the background i’ve created (below ALL layers, essentially). is there a way to make sure it only appears behind the layers contained within my rig?

Make sure your background is below all other elements. You shouldn’t need to have the arm in 0.008 B, 0.001 B should be enough. But you can put the BG, for instance, in 0.010 B.

There are several ways to change the Z depth of any given element or peg. Via Layer Properties or editing the parameters on the Timeline, as I mentioned previously, but also by using the shortcut Alt + Up Arrow and Alt + Down Arrow and by using the Maintain Size tool (on the Advanced Animation toolbar) on the Top or Side views. You can use other tools, but this one, as the name suggests, will not scale your layers as you bring them closer or further away from the camera. The top and side views are good to setup a multiplane. If you just want to organize a rig, it’s better to use the minimum values possible, so careful not to click too much Alt + arrows. The parameters area on the timeline allows perfect control of those values especially if you need to animate them with keyframes.

Make sure the Animate button is turned off if you want to adjust the layers for the whole scene. Otherwise you will animate those positions on the Z axis (which you might need to do when a layer needs to pass behind or in front of another one).


Luis Canau