PROJECT FILE: SIZE: 453 MB (TBS 4.0 WONT OPEN IT)

Hi, I recently finished animating an 11 minute long cartoon. It’s set up in scenes, 500 frames per scene, equaling 17 scenes. The overall size of the project file is 453 megabytes. And TBS 4.0 won’t open it. It takes over 10 minutes to open and then I get a message telling me that Toon Boom Studio has stopped working. I have a hard drive of 320 GB. Over 100 GB are already used up. There’s 2 GB of memory. It’s Windows Vista. Why is my project taking so long to open? It’s so small! PLEASE HELP ME! Is there like a file size limitation to TBS or something? PLEASE RESPOND WITH HELPFUL ADVICE!

Thank you,
JP

Using TBS 4, OSX 10.4.11, 3GB RAM

Well, I guess, one would be well advised to keep every project-file as small as possible…
and rather split the project apart into smaller more manageable files-sizes…
and assemble those later in any video-editor or compositing software…

A single project-file of 453 MB, I presume, is fairly large for any software to handle…

Just an example: My latest project, 4:38 min, altogether about 612 MB, but split apart into about 50 separate project-files, only a few bigger than 20 MB, even some of those, more complex ones, TBS was working already very hard on it…

Cheers
Nolan



I had a similar problem when ToonBoom would crash when dragging-and-dropping a range of elements within the Timeline. The project was, round about, 450Mb in size…
I reduced the size size of many of the elements, replacing vectorized bitmaps with vector images. One thing I did also notice, is that the project size did not necessarily reduce in size automatically until I saved the project to a new project file.

Version 4.5 may help since it has been designed to import video footage (which I’m assuming is fairly large in size).

I’m now producing separate scenes and editing them together with a video editor (as the last user suggested).

You may be running into system resource allocation issues when loading this large project file.

If your system RAM is typical (approx 2 to 4GB) and you also assign approximately 1/4 to 1/2 to TBS, and then are also loading a nearly half-gigabyte project file (which requires assetts to be assigned, vectors calculated, bitmaps either handled by CPU or assigned for GPU handling) you are approaching the limits of what your system might be able to handle. If you have only 1GB or 2GB, you may be heavily overtaxing your system’s memory resources between HDD reads and allocation of system RAM.

As far as I can tell there is no “cap” on TBS file sizes other than what is dictated by 32-bit application rules in Windows. The technical 32-but file size cap is 2GB, which is obviously well under your project size. However, when factoring in other concerns, such as OS overhead, background apps, APIs, system services, drivers, etc, your system resources begin to get thinner. I would also hazard a guess you are running 32-bit Vista which means if you have 4GB you are realistically able to utilize somewhere between 2.5GB to 3.5GB depending on system resource overhead.

1. Defrag the HD where your project file resides (back up your work first).
2. Defrag the HD where Vista boots from (if different from your TBS drive).
3. Allow Vista to handle virtual memory allocation (but if Windows is allocating less than 1GB then manually change it to 2GB and reboot).
4. Unload unnecessary programs/services, etc. (ie Aero, widgets, etc)
5. Reduce system resource usage by lowering your screen resolution if possible.

Boot clean and load TBS and before attempting to open your project file, open TBS’s preferences and limit its memory usage to roughly halfway on the sliders, for both Video and System RAM. Disable “smoothing” and such, and then exit TBS after you’ve saved your changes to preferences. Reload TBS and attempt to open your project file again. I would recommend that at this point you immediately begin to find a way to split your project into more manageable chunks, but that depends very much on how you have created your animation.

I hope something here helps, and good luck to you!