problems with cutting frames

So I’m animating along, no problems and then I decide that I’ve messed up and need to redo a section.

Now using command+x, which used to work in digital pro, gets rid of the keyframes but also deletes the drawings on that frame leaving me with a blank frame in the middle of my animation.

I have the shortcut to remove keyframes as x which gets rid of the keyframe no problem but leaves the changed drawing on that key. This is incredibly annoying. the only way to get rid of the unwanted changed drawing is to open the timeline and cut each unwanted drawing out one at a time. Tedious and time consuming. not good for time management.

So does anybody know of a way to keep the timeline collapsed and be able to clear out the keyframe and any changed drawings without it leaving a totally blank frame behind?

I am running up against the same issue. Does anyone know how to delete the keyframe without deleting the drawing?

Marcus no, and Horuni no, I don’t know how to do those things, but while we are at it, does anyone know how to add frames to the timeline to play with timing/spacing? i ended up with one BIG Shushi bowl of frames and bones all over the damn place, and with something SO simple as adding frames to the timeline.

1. which animate software does it refer to?
2. what system are you on?
3. if on a mac, doesn’t ‘fn+SHIFT+F6’ work for you? it removes the keyframe and restores the old drawing state.

Hey Rob!

I’m on Animate Pro (harmony) on the new iMacs with Snow Leopard.

I tried fn+Shift+F6 and nothing happened. do you know what shortcut you’ve got that hooked up too? I’ve looked over every shortcut I could think of and none of them cut the frame and remove the drawing.

I’m not sure if this is exactly what you’re talking about but I usually just collapse the timeline and select whatever keys I’d like to move around and just drag them to where I want them instead of adding frames in between keys.

i assume the menu items are similar in animate pro and non-pro.
it’s after selecting a cell in the timeline: you can add a keyframe with a F6 or remove it with a F7. with me works for the deletion a SHIFT-F6 too.

function keys (F1-F12) work with fn-function key on a mac keyboard…

you haven’t said anything about deleting a cell, it’s for adding and deleting of keyframes.

oh no I have no problem removing keyframes. the problem arises when I remove the keyframe but any changed cell drawings stay behind.

Alright it’s a bit complicated to explain. As an example say I have a forearm and a hand pegged together.

So on frame one I have a key and forearm and hand are both drawing 1 in a collapsed timeline. Then I make a keyframe on frame 2 and change the hand cell to drawing 2. Forearm is still drawing 1. Then if I hit “x” The keyframe on frame 2 is gone but the hand is still drawing 2. if I use “Command+x” to cut the frame out then the keyframe is gone, the hand cell is back to drawing 1 but now there is no cell at all for the forearm.

The only way I’ve figured out how to get rid of the keyframe and whatever changed drawings is to hit “x” to remove the keyframe and then to manually go into whatever layer that has the changed drawing and cut it there. It works but it adds a lot of time expanding the timeline individually cutting any changed drawings on that frame and then collapsing again to resume working. It’s a really annoying interruption and so I’m trying to find any shortcut that will remove the keyframe AND the cell without leaving blank frames behind.

i get what your trouble is, but i can’t figure out any workaround in the moment. for the last three months i’ve worked only with symbols and substitution drawings in the inverse kinematics modus.
i haven’t used drawing cells for a long time, so i can’t reproduce your scene, sorry.
maybe some other guy can help you.