Problems i encounter in ToonBoom Animate

Problems with ToonBoom Animate:

- Not possible to import video resolutions other then 768 x 576. They all scale to fit 768 x 576
- The keyframe mode works as an element mode
- not able to detect layers created in adobe illustrator.
- not able to import illustrator files created in cs3 or higher

Hi,

I think we have just answered this by e-mail to you:

- Not possible to import video resolutions other then 768 x 576. They all scale to fit 768 x 576

Images/videos will always be scaled to the resolution of your scene by default. You can play with the alignment rules inside the read module of the element to change the rules used for imported images. This being said just keep in mind that the image will be set by default to the resolution of your scene, but it does still keep its original resolution. Therefore if you have a 1000x1000 image imported in a 500x500 scene you could scale your image 2 times its original size to recover the original resolution while keeping the full quality of the file.

- The keyframe mode works as an element mode

There are differences in the way Animate works compared to Digital Pro. Using the select tool no longer creates keyframes even if in Animate mode. You need to use the transform tool to set keyframes now.

- not able to detect layers created in adobe illustrator.

It seems to be working here. Make sure that all your layers are on the first level of the Illustrator file. We do not extract sub-layers (layers under layers) so everything that is find underneath another layer will be merged to the top layer once imported inside of Animate.

- not able to import illustrator files created in cs3 or higher

Adobe blocked access to their file format since a couple of years. Therefore, any special feature that they might have implemented inside their software is no longer reachable from us, making it impossible for us to decode their data input. We base ourselves on the pdf aspect of those file they generate (which is opened source information). Therefore it is possible for us to decode their files partially but some of the newer effects may not import properly. This being said, creating a file in CS3 does not necessarily imply that you have used such options in the creation of your artwork and you should be able to import part of the .ai file regardless. If you can’t import at all make sure you install the patch for the software. If you want you could send us sample files that are not working so we can analyze the situation in detail.

Regards,

Ugo

i have the same problem as the OP. layers from .ai are lost on import.

please explain again HOW EXACTLY this should work?
(please include every little step, regardless how minute!)

what i did:

i have a simple illustrator testfile. 3 layers, each containing ONE filled rectangle in different colors. they overlap slightly. the layers are NOT sublayers, they are layers like in photoshop. each one contains one path. it says “3 layers” on the bottom of the layer panel.

i then save it as an legacy illustrator 10 file with default checkmarks set.

in animate pro i make the library writable and import the .ai file.
it imports
i the drag it to the network view and connect it to the main comp.
(it`s the same if i drag it directly into the timeline!)

it asks to link or copy the palette - i select copy. (no different if i select link)

it recovers the palette as soon as its visible in the camera view.
it looks like it should look (i.e. the same as in illustrator before)

all fine so far i think…

BUT:

i do not(!) have any layers in the timeline.

it does not(!) behave as written on manual page 404!

→ "The Illustrator file layers should now appear in the timeline as separate layers, with the sub-layers collapsed into their corresponding parent layer."

they do not!

i tried this on vista business 64 and xp pro 32bit,
same result!

as i wrote in a previous post, i also tried every ai format known to man (i.e. all formats offered inside illustrator cs4).
i can even import a cs4-ai- file directly into animate pro, but with the same problem (no layers!)

maybe i missed some important step? i absolutely NEED this feature in the near future.

many thanks!


Does the .ai file or its layers appear in the Exposure sheet? It’s possible that it got imported inside some other (selected at the time of import)
element. To know for sure you should contact support@toonboom.com
to get them your project. since the image IS inside your project, it
just needs to be located.

I suggest running it on a 32bit system as the software is not supported
under Vista 64bit.

-ron

it does show up in the xsheet the same it shows up in the timeline…as ONE layer :’(

its not imported inside of any other element. (empty scene)<br /><br />i see the image as it should look like! thats not the problem. just that there are NO layers after import :’( it`s just one flat image.
according to the manual i should get independent layers. in this case 3.

i tried it on both 32 and 64 bit.

thanks anyway :slight_smile: