problem with nudging parts backward and forward

Hi,

I’m doing my rigging on harmony, and I’ve created some hierarchy between the parts of the character, using a peg for all the character too.

I’ve read de “help system” to create my puppet. It’s written that there is 3 ways of organising the different parts of the body :

- by putting one layer on the other (exemple: the eye on the face) ;
- by puting the right position of each element to the other in the network window ;
- by using the shortcuts “alt+up” and “alt+down”.

I would like to use this last way, because I’ve already organised my layers and my network, but I need to change the organisation in the time, when I’m on another frame.

(exemple : the puppet is seen by face, and the next frame is the profile, I need to nudge the arm behind the body)

It doesn’t work.

I’ve probably missed a step, or I don’t know something important before doing that.

Could you help me finding a solution please?


Thanks


Ani

Make sure that you have the transform tool active. Are you working in symbols? If so you’ll need to go inside the symbol, then nudge, then come back out again to see your results. Also, if you want the position to be different (i.e. you want to keyframe the nudge) then make sure that you have the Animate button enabled so that it creates a keyframe when it nudges.

~Lilly
Toon Boom Support

Thank you for answering my question :slight_smile:

I’m working with symbols, parents and pegs.

In fact, I verified this points, and it didn’t work.

But, I found another solution. Maybe it isn’t the logical solution but it’s working :
I enable the 3D mode and 3D path in the properties of each layer. After that, I open the 3D perspective view and I change the organisation of the layers frame by frame using the translate tool.

That permit me to change the organisation of the layers. But the shortcuts still refuse to work. :s

First off, just do a quick check for me to see what set of shortcuts you have enabled. Go to Edit > Preferences and in the Shortcuts tab, which style of preferences do you have enabled from the drop-down list? Is it Toon Boom Harmony/Digital Pro? Also while you’re in here click the “Restore All Defaults” tab in case something got reassigned.

Okay so if you’re working in symbols, then do me a favour and do a quick test for me. Create a new symbol. Double-click to go inside the symbol. Now, create two layers, and create a drawing on each layer. Just do a quick brush stroke, one on each layer, in different colours so that you can see quite easily if they switch position.

Now, select one of the layers with the transform tool. Make sure the “Animate” button is enabled. Use the shortcut - are you on Mac or Windows? It’s Alt-Up / Alt-Down on Windows, and Option-Up / Option-Down on Mac. Do you see a keyframe being created on the timeline, even if you don’t see any movement in the camera view? You should only have to nudge it a few times to see the layers flip position.

~Lilly
Toon Boom Animation

It works when I do this test. (I’m on PC).

I restored all the shortcuts and now it’s working.
But isn’t it possible to save his own shortcuts?

I also loaded the puppet which is on the site, to analyse how it is built and which option I should cross in the layer’s properties : apparently, it’s working now that I disabled the 3D, but left the 3D path enabled.

So what’s the 3D enabled mode for? what’s the difference with the 3D path?

Thank you for your precious advices.

The 3D path allows you to enter and edit Control Points. When you animate something with the transform tool, you can hit Shift-F11 to Show Control. This will show your path. If you are working with a 3D path, you can add and edit points in your path.

For more information on this topic, see pages 508-516 of the User Guide.

~Lilly
Toon Boom Support