problem with eraser tool

Hello! I’m having a problem in my animate pro 2. I seems whenever I try to use the eraser tool, it LOOKS like it erased what I wanted it to for all of 2 seconds, then the erased segment comes right back. Its frustrating! If anyone could help, id be very thankful!

Some info in advance: I’m running Animate Pro 2 on my Windows 7 laptop with Aero mode disabled.

Thanks in advance!

First I am a mac user and don’t have a clue on PC’s.
Have seen from other posts that Aero has caused problems.

Now. Make sure you are working on the right layer.
If in cameraview, working in another layer will cause the reactions that you are describing. Change to the layer you want to erase.
The same for working in drawing view with the advanced drawing enabled. That to say working in color art layer the artwork in the line art layer will not be affected. That also apply to the eraser.

If the of above mentioned does not work I don’t know.

Best regards

hey ivaar! I just tried it, unfortunately it didn’t work. Thanks though!

Perhaps you try to erase the pencil line, which is one vector line, and sometimes behave like this. Try to select it with a selct tool and click in tool properties on the button “pencil to brush”, and then erase.
Remember that pencil line, is one vector line, which means that you cant interfere in it shape with contour editor or eraser.

i hope i helped

Hi Jonathan

Have you solved the eraser problem?

i’ve tried the remedies and still no avail. To make it better on you guys, I decided to make a video of it on my livestream that way you can see it with your own eyes.

The link is here, as I couldnt embed it into this post for some reason:


It really looks odd.
But I have now managed to recreate a similar behavior, by checking of for both options for the Color Protection.

So go to the top meny and make sure there is not
more than maximum one cheque mark:

Top Menu -Drawing -Color Protection -

If both have a cheque mark, I have the same issue as you.

Best regards


If ivaar’s suggestion doesn’t resolve your issue, try this.

Please select the eraser tool and then go to the Tool Properties panel and scroll down so you can see the part below the brush preview. Make sure that “Use Blur Parameters” and “Keep Vectors” are NOT checked. I began experiencing your problem only after I checked these two. Everything returned to normal after I unchecked them.

It seems that there are at least two ways to duplicate your issue.

I just tried to uncheck the boxes in the eraser tool properties. it works! Thanks guys!!

I’m glad it worked!

One of my students is having the same problem with the soft eraser, but we are using regular Animate (not Pro), and I don’t see the boxes to uncheck at the bottom of the eraser tool bar. Does anyone have a screenshot of this or know how to fix it in regular Animate. It seems to only be a problem with the soft brush.

Thank you! So many years later and your posting is still helping!

Animate has the “Tool Properties” window also. Select your eraser tool and then go to the “Tool Properties” window. Then click on the GreyTriangle-on-VerticalRectangle button after the visual representation of the line to access the “Advanced Properties” of the tool. The checkbox for “Soft Tip” is on the advanced properties window that appears (in the section called "Soft Eraser).

not only is my eraser not working, but I am not seeing these option boxes. Is there some preference I need to select to see these options?


I am using Animate Pro 3 not Pro 2 so maybe this changed but those options are available in a separate Extended Properties window that is opened when you click on the triangle next to the current eraser sample at the very top of the Tool Properties window when the eraser is selected. Look at the area at the top of that Tool Properties window. You see the tip shape. Then to its left (our right) there is a slash representing the sample of the current eraser. Directly connected to that sample’s border is a triangle pointing to our right indicating that it can be expanded. If you hover over it you will see “Show Extended Properties” so click on that and an additional window with these options opens.

I had the same problem, I was trying to erase some lines done by the pencil tool in correct layer.

What worked for me was change the erase settings, on the Tool Properties Panel, I changed ‘Soft Eraser’ to ‘Eraser’