Problem syncing sound to panels

I’m editing an existing storyboard session, it needs to stay in sync with the single audio track I’m using. Every time I delete a panel or edit it’s length all of the panels that follow “slide” out of place forcing me to realign all of them after each edit. I’ve tried “linking” to sound but it doesn’t seem to work. Any suggestions.

If you want to change he duration of a panel without affecting the ones after it, hold down the option key (Alt key on pc?). If you have a single continuous soundtrack, I think it’s impossible to delete panels without affecting the sync. If you’re editing to dialogue though, use the Split Sequence button to break the lines up and they will move with the panels (with linking turned on).