Problem importing image .ai

Good evening.
I’m having trouble importing ai pictures
Import some and not others, when I pull the image to the composite nothing happens, but there is none.

Does anyone know what is causing it can?

Yay! Glad it’s working :slight_smile:
Colour recovery is just Harmony’s way of saying “Whoa, I don’t have these colours in the current palette. Do you want me to add them?”

Yeah, image import works without any trouble.
And I now imported an .ai file again and dragged it into the stage.
It asked for color recovery, I clicked yes, and my illustrator image shows up now! Great. :slight_smile:
No idea what went wrong before, maybe I was accidentally working on a clipping mask layer (cutter) in that moment, could that be?
Or I denied color recovery. I have no clue.

Anyway, now everything’s at it’s perfection! I love it!

Thank you so much for helping me out.
By the way, I’m still on 12.1, so yeah, it’s time for an update. Thanks for the tip. :wink:

Alana have you got the latest version of Harmony installed? You can download it from your user account. Good luck!

Alright here’s a screen capture:

Once I’ve clicked on a file to import there’s just nothing to see.
Or have I missed anything?

Woo hoo! Getting there. Your file being converted to .tpl is normal, like you said it’s being converted to a template to be used in Harmony. However, you should be able to drag the template file to the stage and be able to work with it. The file you uploaded should also have 2 layers like it did for me. Have you tried importing jpegs or any other file formats to your library? Were you able to see them/use them? Also, do you have the latest version of Harmony installed? You can download the latest version from your Toon Boom user account. Harmony doesn’t check for updates automatically so you need to check in with your user account occasionally.

Also, try drawing something on the stage and then store it in your library as a template. Delete it from the stage. Now try dragging the template you’ve created from the library to the stage. Does it work? Just trying to rule out something wrong with your library.

Once you’ve imported your file into Harmony, how are you getting it to appear on the stage? Are you able to screen capture what’s going wrong?

Thank you for your efforts.
Do you think it could be caused by El Capitan?
Have been using EC for months now so I never had the chance to test Harmony with Yosemite.

By the way, I just tested importing some .ai files into Toon Boom Studio.
For any reason I can also import without any issues there, but Harmony still refuses to.
So it really seems to be a Harmony thing.

Import using your file worked for me too! I’m using Harmony Premium and I’m on a Macbook Pro running Yosemite 10.10.5. I screen captured the import:

Both files import without any problems creating 2 layers: “Ebene_1" and “Ebene_2”

Using Harmony Premium Version 12.1.0 (10414) Mac OSX 10.10.5 “Yosemite”.

Sure, just grab these.

Version 9:

Version 10:

Now I’m curious.
Hope it helps finding a solution.

Thank you!

Any chance you could provide a link to one of your ai-files ?
Might be interesting to check if I could import that file here.

someone has a solution to this problem, and I have one week struggling with this problem and can not find a solution, someone who can help please

Did you right-clicked your Library-Folder and selected “Right to Modify” ?
Did you export as “Legacy Format” AI 9 or 10 ?
Did you select “create PDF compatible file” ?



Double check… :frowning:

Have tried that about 1000 times already, but nothing helps. Right to modify is given, otherwise it would come up with an error message that it’s read-only.
Concerning legacy… have tried all of them from CS6 down to 3.
PDF compatibility is always checked by default.

I still think there must be a connection between the issue and the fact that I’m on CC 2015, no matter whether I use legacy or not.
There must be something wrong with CC and legacy export…
Because everyone here saying it’s working for him/her is still using CS6 or older.
Maybe there’s a difference between exporting from CS6, and exporting in legacy mode from CC.
Can’t think of anything else anymore…

Same problem here. Harmony just doesn’t let me import .ai files.
It won’t even give me an error message, it just stays empty and nothing happens after using the import function.

That has already been a topic which can be found here for example, but there are a few more:

Have tried anything so far but nothing helps.
Could it have anything to do with CC? 'Cause I’m using CC 2015.
Even when I save it in legacy mode it won’t work.

Anyway, I’d really appreciate a solution to this, because it’s annoying as hell and interrupting my workflow.

Have you tried importing any other types of images? Have you tried saving templates in your library? I’m just trying to rule out any issues with your library because I can’t see anything stored there at all.

Hi Alana,
Please send an email to and we will open a ticket and follow up.

Hello DessieX,

sorry for being late!

Well, I’m one step closer to success.
Don’t ask me why, but for any reason I can now import files and they actually show up in the library panel. =)
Just tested it out again and it suddenly worked, I don’t know why.

But one thing’s still weird.
When I import an .ai file, Toon Boom automatically converts it into a .tpl file (which means template file, I guess).

Is that even normal?
I’m wondering because I can’t really work with that .tpl file in my library. I drag it into my scene and it’s invisible.
However, I can see it in the preview window right next to the library panel.

Video is set to private