Problem coping colour art layer to overlay art

Guys, I don know what’s happened (maybe clicked smth wrong at some point), I want to do shading in overlay art, so I copy colour art layer to paste it to OAL but some of the visible strokes disappear. I am just trying to copy paste it then unpaint and do the shading. It worked with some other character yesterday though.

screen recording is in the link

You use the lasso tool to select. Maybe you dont select all the lines then. better to use the Marquee.

If you are copying between artlayers this script is useful:

I hope it helps.

I tried both marquee and Cmd A, doesn’t change anything, like I said it all worked yesterday, and I do not remember adjusting any preferences or anything like that.

It’s annoying when it is like that. Could be something selected in some way. Hard to know.

Try the script and see if it works.

I am sorry, it was just smth really stupid, it actually was not deleting anything, it was covering visible strokes with pure colour in overlay art… so when I tried it again selecting pasted layer and unpainting it, the image went back to normal. And invisible strokes were there so I could add more for shading… I just overlooked it yesterday when it actually worked cause I wasn’t paying attention to how the pasted image looked because it was highlighted by selection strokes if you know what I mean… I will just leave it here in case I will need the script you sent me, thank you!

Great that you solved the problem.

That’s the process of learning ( and hopefully not forgetting when it happen again )